Question

Locked

Switch Port goes down & up after few seconds..

By kunal.khandait ·
Hello,
At our EXTREME swtches all ports goes up & down at regular interval. The sample of the port Log is given below. All ports are AUTO negeotiable speed. I am enable to troubleshoot the issue. Help me out.

03/12/2009 15:08:46.52 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 1:8 link UP at speed 100 Mbps and full-duplex
03/12/2009 15:08:47.07 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 1:8 link down
03/12/2009 15:08:48.92 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 1:8 link UP at speed 10 Mbps and full-duplex
03/12/2009 15:09:08.69 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 1:44 link down
03/12/2009 15:09:10.34 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 1:44 link UP at speed 100 Mbps and full-duplex
03/12/2009 15:09:10.99 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 1:44 link down
03/12/2009 15:09:11.37 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 1:14 link down
03/12/2009 15:09:12.94 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 1:44 link UP at speed 10 Mbps and full-duplex
03/12/2009 15:09:12.97 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 1:14 link UP at speed 100 Mbps and full-duplex
03/12/2009 15:09:13.67 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 1:14 link down
03/12/2009 15:09:15.47 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 1:14 link UP at speed 10 Mbps and full-duplex
03/12/2009 15:32:00.93 <Info:AAA.authPass> Slot-1: Login passed for user admin through telnet (172.27.26.13)
03/12/2009 15:32:11.08 <Info:AAA.logout> Slot-1: User admin logout from telnet (172.27.26.13)
03/12/2009 15:51:26.67 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 3:39 link down
03/12/2009 15:51:29.33 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 3:39 link UP at speed 10 Mbps and full-duplex
03/12/2009 15:52:08.73 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 3:39 link down
03/12/2009 15:52:10.98 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 3:39 link UP at speed 100 Mbps and full-duplex
03/12/2009 15:52:27.62 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 3:39 link down
03/12/2009 15:52:29.33 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 3:39 link UP at speed 100 Mbps and full-duplex
03/12/2009 15:55:22.09 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 2:38 link down
03/12/2009 15:55:24.59 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 2:38 link UP at speed 10 Mbps and full-duplex
03/12/2009 15:57:33.28 <Info:vlan.msgs.portLinkStateDown> Slot-1: Port 1:48 link down
03/12/2009 15:57:37.28 <Info:vlan.msgs.portLinkStateUp> Slot-1: Port 1:48 link UP at speed 10 Mbps and full-duplex


Thank You !!
Regards,
Kunal K.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Duplex

by Wizard-09 In reply to Switch Port goes down & u ...

Ensure that the other ened it set to match your full duplex mode, so if your port is set to full duplex ensure that the nic on the computer or server is enable as the same.

Keep us informed as to your progress if you require further assistance.

If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as Helpful so that others may benefit from the outcome.

Collapse -

DUPLEX

by kunal.khandait In reply to Duplex

Hello,
Thanks for your response. But we have set the Duplex mode setting of ports to AUTO. And the end devices are in AUTO mode too.

Thank You!!
Regards,
Kunal K.

Collapse -

I hate to state the obvious...

by cmiller5400 In reply to DUPLEX

But it ain't negotiating correctly. Set the switch and the device to 100/full and be done with it.

Collapse -

Devices

by Jellimonsta In reply to Switch Port goes down & u ...

What devices are plugged into the ports in question? If they are workstations, it may not be uncommon for them to go up and down multiple times a day (even more so if laptops).
If they are workstations and you want to keep the logs a little cleaner, you should look at removing link status from user ports. On a Cisco switch this is done with 'no logging event link-status'. Unfortunately, I have never touched an EXTREME switch, but I imagine it has a similar command. Either snoop around the switch, or use the command reference help on their site.
Good luck!

Edited to add: This link may help. http://apps.extremenetworks.com/LIBRARIES/whitepapers/technology/LinkFilterFeature.pdf

Collapse -

Auto-negotiation flip-flopping is a very common issue

by robo_dev In reply to Devices

At a very large site I worked at (around 10,000 ethernet ports, all on Extreme switches), we would setup every switch to be 100/full by default and leave the devices set to auto. While every once in awhile a device would mis-negotiate, that was not very common.

The other issue that may be indirectly involved is spanning tree. On a flat network you do not need to have it enabled....I'm not sure that spanning tree could mess up auto-negotiation, but it does delay your device connection, which is not good.

Collapse -

That's why..

by cmiller5400 In reply to Auto-negotiation flip-flo ...

You use the command "spanning-tree portfast" :), oh wait a minute, they don't use Cisco

Collapse -

Funny Miller

by Wizard-09 In reply to That's why..

You are in a funny mood today Miller thats 2 reply i have seen to be funny the other was about a CD drive lol

Collapse -

:) I'm kind of slap happy today...

by cmiller5400 In reply to Funny Miller

with a twist of sarcasm and a pinch of malevolence ]:) . Probably from my lack of sleep.

Back to Networks Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums