Question

Locked

Synchronising the network clock with DC

By mrpunjab ·
We have a Windows network with Server 2003 on the DC and the Storage server. The workstations are a mix of Vista's, XP's and 2000.

The trouble is that after the Day light saving our DC was updated no problem, the Storage server is still an hour behind and so are some of the work stations.

I want to the DC to pick up a time from external source and let member servers and other work stations synchronise their time with DC.

I got the following from another forum:

net stop w32time
w32tm /unregister
w32tm /register
net start w32time
w32tm /sync /rediscover /nowait

On the last command my machine gives me error as /sync is not recognised command.

Please help. Thanks

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Check your command syntax

by Jacky Howe In reply to Synchronising the network ...

it should be resync. Reccommended w32tm /resync /rediscover
<br><br>
<i>Keep us informed as to your progress if you require further assistance.</i>
<br><br>
<i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
</i>

Collapse -

Did still doesn't work

by mrpunjab In reply to Check your command syntax

I did eventually figure out the /resync issue, but the time still is not in sync.
I even set my DC to get time from NTP.

DID all below:
*********************************************
Configuring the Windows Time service to use an external time source
To configure an internal time server to synchronize with an external time source, follow these steps:1. Change the server type to NTP. To do this, follow these steps:a. Click Start, click Run, type regedit, and then click OK.
b. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters\Type
c. In the right pane, right-click Type, and then click Modify.
d. In Edit Value, type NTP in the Value data box, and then click OK.

2. Set AnnounceFlags to 5. To do this, follow these steps:a. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config\AnnounceFlags
b. In the right pane, right-click AnnounceFlags, and then click Modify.
c. In Edit DWORD Value, type 5 in the Value data box, and then click OK.

3. Enable NTPServer. To do this, follow these steps:a. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpServer
b. In the right pane, right-click Enabled, and then click Modify.
c. In Edit DWORD Value, type 1 in the Value data box, and then click OK.

4. Specify the time sources. To do this, follow these steps:a. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters
b. In the right pane, right-click NtpServer, and then click Modify.
c. In Edit Value, type Peers in the Value data box, and then click OK.

Note Peers is a placeholder for a space-delimited list of peers from which your computer obtains time stamps. Each DNS name that is listed must be unique. You must append ,0x1 to the end of each DNS name. If you do not append ,0x1 to the end of each DNS name, the changes made in step 5 will not take effect.

5. Select the poll interval. To do this, follow these steps:a. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpClient\SpecialPollInterval
b. In the right pane, right-click SpecialPollInterval, and then click Modify.
c. In Edit DWORD Value, type TimeInSeconds in the Value data box, and then click OK.

Note TimeInSeconds is a placeholder for the number of seconds that you want between each poll. A recommended value is 900 Decimal. This value configures the Time Server to poll every 15 minutes.

6. Configure the time correction settings. To do this, follow these steps:a. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config\MaxPosPhaseCorrection
b. In the right pane, right-click MaxPosPhaseCorrection, and then click Modify.
c. In Edit DWORD Value, click to select Decimal in the Base box.
d. In Edit DWORD Value, type TimeInSeconds in the Value data box, and then click OK.

Note TimeInSeconds is a placeholder for a reasonable value, such as 1 hour (3600) or 30 minutes (1800). The value that you select will depend upon the poll interval, network condition, and external time source.
e. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config\MaxNegPhaseCorrection
f. In the right pane, right-click MaxNegPhaseCorrection, and then click Modify.
g. In Edit DWORD Value, click to select Decimal in the Base box.
h. In Edit DWORD Value, type TimeInSeconds in the Value data box, and then click OK.

Note TimeInSeconds is a placeholder for a reasonable value, such as 1 hour (3600) or 30 minutes (1800). The value that you select will depend upon the poll interval, network condition, and external time source.

7. Quit Registry Editor.
8. At the command prompt, type the following command to restart the Windows Time service, and then press ENTER:
net stop w32time && net start w32time
*********************************************

Time still not sync...??

Collapse -

Check out the Troubleshooting section

by Jacky Howe In reply to Did still doesn't work

How to configure an authoritative time server in Windows Server 2003
<br>
http://support.microsoft.com/kb/816042
<br><br>
One possible cause of this problem is that the Windows Time Service, W32Time, is not started or it is set to the wrong time.
<br>
The Windows Time Service must be configured with Automatic start up.
<br>
To resolve the problem:
<br>
1. Administrative Tools / Services.
<br>
2. Double-click Windows Time.
<br>
3. Set the Startup type to Automatic.
<br>
4. Start the service.
<br><br>
NOTE: If the Startup type was Disabled, you will have to restart the server, but you may want to do it anyway.
<br><br>
<i>Keep us informed as to your progress if you require further assistance.</i>
<br><br>
<i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
</i>

Collapse -

SBS2000

by Churdoo In reply to Synchronising the network ...

You said in another post that you have an SBS 2000 server. What's the status of the time on that server? I'm expecting that to be off by an hour, and would be the reason for the others being off. Even though you have a 2K3 DC on your network, the SBS 2K would be holding FSMO roles and would be the authoritative time source on your network.

Does your SBS 2000 box have the correct DST schedule? When the DST schedule changed in the US a couple years ago, XP and 2K3 were updated by way of MS updates, however 2K were not, and we had to do registry edits to enter the modified DST schedule.

Collapse -

DC has the FSMO role

by mrpunjab In reply to SBS2000

The Domain Controller is holding FSMO role. I confirmed that in my AD before I put this post.

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums