General discussion

Locked

System Policy Editor

By ithelpdesk ·
Ok, this is so frustrating. I ran the SPE and checked the "only run allowed windows applications". I specified the application that the pc is allowed to run. This was my path that I wrote down:

"c:\program files\microsoft office\office\winword.exe"

c:\poledit.exe

I went back into windows and tried to run the applications, just to test it out...would not let me, nor it would not let me run regedit or other applications(which I did not specify for it to restrict).

I reinstalled win98 hoping that it would help, but did not.

So, my question is...is there a way to get into the policy editor without having to reformat the hard drive and reinstall all programs?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

System Policy Editor

by ithelpdesk In reply to System Policy Editor

I get "Restriction" Error Msg in everything or anything that I want to open.

Collapse -

System Policy Editor

by Gigelul In reply to System Policy Editor

"Run only allowed application"
This means that you must add here all <exe>, <com>, <bat> files (use find to the all entire HDD) and ignore the application you want to restrict for running.
About recover. I'm not sure but you can try pressing F8 key at boot sequence, enter in command prompt, find files with *.pol extension and delete it.

Collapse -

System Policy Editor

by Gigelul In reply to System Policy Editor

For more detail read about policy:
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/win98/reskit/part2/wrkc08.asp

From same source:
You used the policy named Only Run Allowed Windows Applications, but then you could not turn off this policy because you forgot to include Poledit.exe in the list.

Did you set this policy for all users? If not, log on as another user, and run System Policy Editor to cancel this policy.
If you can run Registry Editor, go to the following key and delete the RestrictRun entry:
HKEY_CURRENT_USER \Software \Microsoft \Windows \CurrentVersion \Policies \Explore

If you previously set this policy for the Default User, and as a result, no user can run System Policy Editor or Registry Editor, try the following:

If possible, disable user profiles in the Passwords option in Control Panel. You should be able to log on and run System Policy Editor. Then undo the policy and re-enable user profiles.
If you cannot disable user profiles because the Passwords option in Control Panel has been disabled, you must either rename the policy file on the server and logon as a user who has not logged on at the computer and change the policy, reinstall Windows 98 (so that userprofiles will not be enabled), or use the Windows 98 startup disk and run the real-mode Registry Editor to disable user profiles.

Collapse -

System Policy Editor

by ithelpdesk In reply to System Policy Editor

This did not help me. Is there anything else I could try?

Collapse -

System Policy Editor

by Gigelul In reply to System Policy Editor

Read again previous answer.
If you can't apply these tips all you can do is to perform a fresh install/reinstall.

Collapse -

System Policy Editor

by ithelpdesk In reply to System Policy Editor

Poster rated this answer

Collapse -

System Policy Editor

by ithelpdesk In reply to System Policy Editor

This question was closed by the author

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums