Question

Locked

System restore problem, among other things

By lord_alphathon_iv ·
Hi all,

I noticed today that I cannot create restore points on my main computer. The automatic creation doesn't seem to be working either, which I noticed when, probably about a week or two ago, I had to boot into safe mode due to a screw up causing windows to blue screen on booting (which afaik is completely unrelated to my current problem, the cause of which was a network bridge between my wireless adapter and a virtualbox host interace), but while there, I noticed I had no restore points, which I put down to the recent install of SP1, but when I tried to create one today, there were still none.

When I try to create a restore point, it sits with a loading bar for ages saying "Creating a restore point...", then after about 10 minutes, stops with the following error message:

The restore point could not be created for the following reason:
The creation of a shadow copy has timed out. Try again this operation (0x81000101)
Please try again.


While not the same problem, I am also having problems with installers which may be relevent. A lot of installers (not all, but most) take an incredibly long time to complete. They usually sit at 0% for ages (anywhere from 5 minutes to half an hour) then begin to actually install, but more slowly than you'd expect usually, especially with the specs of my system. I don't know if it is related, but as the problem with the creation of a shadow copy is a timeout I thought I'd mention it. Also, if anyone knows how to solve it then please share as it rather annoying (nothing more really, but still...).

Also, I have noticed recently that my CPU usage has gone through the roof. Normally after startup it remains stable at between 0% and 5%, when idle. But after a while, the CPU stars getting consumed more and more. According to resource monitor it is mainly being consumed by svchost (at the time of writing, svchost was using 98% of the CPU, when all that was running was this firefox window and background tasks). As you can imagine, this is a little concerning. It doesn't seem to be affecting the performance though. These figures are coming from task manager, resource monitor and the screen on my Logitech G15 Keyboard

I have tried google for all 3 of these problems, but to no avail, and virus and malware scans all come out clean.

Other possibly relevent system details:
OS - Windows Vista Ultimate SP1 32-Bit
CPU - Intel Core 2 Quad 2.4GHz (Q6600)
RAM - 4GB DDR2 (I am aware that 32-bit OSs cannot utilise it all)
MOBO - Asus P5K-Premium

This conversation is currently closed to new comments.

48 total posts (Page 1 of 5)   01 | 02 | 03 | 04 | 05   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Have a look here, seem familiar

by Jacky Howe In reply to System restore problem, a ...

http://ask-leo.com/svchost_and_svchostexe_crashs_cpu_maximization_viruses_exploits_and_more.html

From another PC download and install these two programs and copy the the installed folders to a USB Stick.

Restart the PC in Safe Mode and run Sophos when you have completed the 4 steps run Spybot.

Download Sophos and the latest IDE Files. Install it and extract the IDE files to the SAV32CLI folder. I normally create batch Files for the 4 runs. EG: Sav1.bat cd\SAV32CLI SAV32CLI -P=C:\SCANLOG.TXT
http://www.sophos.com/support/knowledgebase/article/13251.html

Running an information scan To run a scan for information only, so as to create a log, type the following at the command prompt: SAV32CLI -P=C:\SCANLOG.TXT This will create a log of infected files, but will not disinfect or delete any infected files. You can then copy the log to a floppy disk for printing or emailing. If you run SAV32CLI without the -P command line parameter, the information on viruses will be written only to the screen. Disinfecting infected files To disinfect infected items with SAV32CLI, use the '-di' command line parameter. If a file is infected more than once (either with different viruses, or several cases of the same virus), you might need to run multiple scans to disinfect all virus infections. Do not use the command line parameter '-remove' in the same scan as '-di', as you could delete a file which could have been cleaned. If the infection on the computer seems to be progressing rapidly, back up your data to CD or DVD before attempting disinfection. The '-di' command line parameter will disinfect infected boot sectors, some infected program (.exe) files, and infected documents (e.g. .doc, .xls). So, if your computer has been infected by a number of viruses, macro viruses, and worms, shut down the infected processes (either manually, or by using safe mode with command prompt), then run a series of scans to disinfect and remove these malicious programs. Make a log of all scans. First run SAV32CLI -DI -P=C:\SCANLOG1.TXT Make a note of the number of files disinfected. Run the scan again, with a different log name SAV32CLI -DI -P=C:\SCANLOG2.TXT If the number of files disinfected has decreased, run a third scan. If it has not, or the number is '0', remove all other virus files: SAV32CLI -REMOVE -P=C:\REMOVLOG.TXT The above scans will disinfect all files that can be disinfected, and remove the rest. During this process any infected documents will have been disinfected. Check the relevant virus analysis to find out if the virus involved could have corrupted data in the document. If you check the logs, you may well find that some worm or Trojan files were infected with a virus, so they were first disinfected, then removed.

Download Spybot - Search & Destroy 1.5.2 and install it. Update it. http://www.safer-networking.org/en/download/index.html

Collapse -

Involvement of cryptographic services?

by lord_alphathon_iv In reply to System restore problem, a ...

OK, so I've tracked down the service that was using up all my CPU during the peaks
- cryptographic services. I don't know if this affects the diagnosis of the system restore problem or not but it would seem connected somehow, as when the cryptographic services is disabled the creation of the restore point crashes again, but much sooner and with a different error message:

"The restore point could not be created because the shadow copy provider had an unexpected error while trying to process the specified operation. (0x8004230f)

Please try again."

suggesting that it is involved in some way with restore point creation. Also the description says it is involved with installation of programs, which suggests to me that it is almost definitelly involved with the slow installer problem

Collapse -

So you've eliminated the possibility of

by Jacky Howe In reply to Involvement of cryptograp ...

a Virus Infection, correct.

Default Settings XP Home : Automatic XP Pro : Automatic
Microsoft Service Description Provides three management services: Catalog Database Service, which confirms the signatures of Windows files; Protected Root Service, which adds and removes Trusted Root Certification Authority certificates from this computer; and Key Service, which helps enroll this computer for certificates. If this service is stopped, these management services will not function properly. If this service is disabled, any services that explicitly depend on it will fail to start.
Dependencies Remote Procedure Call (RPC)
Real World Description Provides the annoying boxes that pop up telling you a driver you are about to install isn't digitally signed. If you disable this service you'll be flooded with uncertified driver notifications.
Is this service needed? Possibly
Recommended Setting:
Manual

Note Updated to reflect SP2 changes.
I set this to Manual and if it's needed it starts. If you get errors or repeated calls for the service, set it to Automatic. A lot depends on how many unsigned drivers are on your system and of what type drivers.

http://msdn2.microsoft.com/en-us/library/aa380245(VS.85).aspx

Collapse -

Not sure what you're getting at

by lord_alphathon_iv In reply to So you've eliminated the ...

"So you've eliminated the possibility of a Virus Infection, correct."

Is that supposed to be a question or an affirmation that it isn't a virus? I'm not quite sure what you're suggesting. (The rest of the post just seems to be a discription of Cryptographic Services). Bear in mind that the creation of a restore point doesn't work with it on OR off, just for a different reason. It may not even be connected

Collapse -

Try this

by Jacky Howe In reply to Not sure what you're gett ...

Uninstall SP1 and see if that makes a difference. If not try this.

1. Open the Start Menu.

2. In the white line (Start Search) area, type cmd

3. Right click cmd (at top) and click Run as administrator.
NOTE: This opens a elevated command prompt.

4. Click Continue button for UAC prompt.

5. In the command prompt, type sfc /scannow

6. Press Enter
It may take a while to finish

sfc /scannow - Scans the integrity of all protected system files and repairs the system files if needed.

Your symptoms also look like Virus activity.

Backup error 0x8004230F

System Restore, 0x81000101 also Backup error

<edit>
If the above doesn't work you could try this.

http://vistasupport.mvps.org/repair_a_vista_installation_using_the_upgrade_option_of_the_vista_dvd.htm

Collapse -

Vista sp1

by Sue T In reply to System restore problem, a ...

Microsoft is offering free support for sp1 problems so it might be worth a call. I haven't installed it on my computer yet but I do believe I will double check to be sure system restore is turned on before I install it. If I remember correctly sp1 is supposed to be removeable in add and remove programs. have you tried uninstalling it and seeing if your problem goes away? Did you have the problem with installers before sp1 was installed? Have you tested your hard drive and checked to be sure your system files are good? Have you installed any software before these problems started? Download and run Autoruns which is a free download from Microsoft and see what is automatically starting with windows as there may be something there. You might also want to download Process Explorer while you are there and see what that has to say. good luck.

Collapse -

Re: Vista SP1

by lord_alphathon_iv In reply to Vista sp1

"If I remember correctly sp1 is supposed to be removeable in add and remove programs. have you tried uninstalling it and seeing if your problem goes away?"

It isn't in there

EDIT: Oh wait, it is. I forgot to look in the "Installed Updates" Section.


"Did you have the problem with installers before sp1 was installed?"

The first one that I had that had these symptoms was the one for google earth, which I installed in mid march, which I think was after SP1 came out I believe. It may well just be that the installer problem is an incompatibility of some version of install-shield with Vista or something though, and I just happen to have come across quite a few which use it. As I said it's not all installers that do it.


"Download and run Autoruns which is a free download from Microsoft and see what is automatically starting with windows as there may be something there. You might also want to download Process Explorer while you are there and see what that has to say."

I already had Process Explorer, thats how I found that Cryptographic Services was at fault for the elevated CPU. I DLed and ran Autoruns, and I couldn't see anything suspicious or unwanted.


Well I suppose I might as well try uninstalling SP1. I'll report back my findings once I have uninstaled it, and once I have reinstalled it.

Collapse -

Not SP1

by lord_alphathon_iv In reply to Vista sp1

I tried uninstalling SP1 and it had no effect, I still can't make restore points - get the same error message as before...now to reinstall SP1

Collapse -

Have a look here it may help

by Jacky Howe In reply to Not SP1
Collapse -

Didn't help

by lord_alphathon_iv In reply to Have a look here it may h ...

Followed the instructions, and it didn't help - said that it didn't find any errors, and just to be sure I checked the log of failed repairs that it produces and it was empty. Thanks for helping anyway

Back to Browser Forum
48 total posts (Page 1 of 5)   01 | 02 | 03 | 04 | 05   Next

Related Discussions

Related Forums