Question

Locked

System Restore Will Not Work Anymore

By danjrussell ·
Previously, system restore has worked several times for me (Windows XP Media Version). However, a couple days ago I got the following message after doing a normal boot-up to start my computer for the day. This error message is constant now when I boot, so I just tried doing a system restore and get a message that my computer cannot be restored to earlier checkpoints. I see in the system restore log that "Software Distribution Service 2.0" had accessed my system the night before I had problems. This same service has previous history in my restore points as well. Is it a legit service???? I don't know. Here is the error msg I get on boot that caused me to want to restore:
"RTHDCPL.EXE Illegal system DLL Relocation. The system DLL user 32.dll was relocated in memory. The application will not run properly. The relocation occurred because the DLL C:\windows\system32\HHCTRL.OCX occupied an address range reserved for windows sytem DLLs. The vendor should be contacted for a new DLL."

A search in my computer for HHCTRL.OCX shows it in a couple locations. One is peoplepc\online. I don't know what that relates to.

Any info would be welcome regarding the problem. I suspect a virus although I have Norton running full time for everything and I never open attachments that cannnot be scanned first.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Some starter thoughts.

by joel.gerstenmier In reply to System Restore Will Not W ...

If you have the original OS cd we can try using the "SFC /scannow" command from the start menu/run. Leave out the quote marks. This will look for corrupt system files and replace them with fresh one's from the OS cd. That would be the first thing I would try.

Collapse -

Great Approach - Thanks Joel!

by danjrussell In reply to Some starter thoughts.

Thanks, Joel. I first ran a complete virus scan (Norton) which came out totally clean. Since my WinXP came OEM, the only CD's that I have are the Recovery CD's that I had made for the computer. I don't want to have to go back to scratch of course. I ran "SFC /scannow" like you suggested anyway. It came to the end and advised me to "insert Windows XP Professional CD2 now". It states further "files that are required for Windows to run properly must be copied to the DLL cache." That seems totally appropriate to me. Unfortunately, like most OEM installations, I didn't receive a set of the Windows CD's with my computer. That always frustrates me. I don't know if I could have made a set or not?? Anyway, what can I do now, seeing as I don't have them?

Collapse -

Any chance..

by joel.gerstenmier In reply to Great Approach - Thanks J ...

Any chance that you can borrow the cd from somebody? It will not matter if its oem or not, it will be happy with any XP Pro cd. Since it is asking then it definitely found some system files that were not quite right. O

Collapse -

Cause & Solution Found

by danjrussell In reply to Any chance..

Thank you again for your assistance. I had contacted HP support via live chat and was surprised that they very efficiently id'd & corrected the problem.

Cause of problem was Microsoft's Security Updates 925902 (MS07-017) & 928843 (MS07-00. The HHCTRL.OCX file that was included in sec update 928843 and User32.dll file that was in sec update 925902 have conflicting fase addresses. The problem occurs if the program loads the HHCTRL.OCX file before it loads the User32.dll file.

THE FIX: Downloaded and installed the fix available from: http:/support/microsoft.com/kb/935448/
After installing fix and rebooting, no error was consequently encountered. I then created a couple of restore points and was able to restore to one normally. Both problems were fully rectified.

Hope this helps someone else as well.
Dan

Collapse -

I thought this was the ticket....

by jalynmac In reply to Cause & Solution Found

I have been having issues with restore as well, it all happened after I downloaded Bitdefender. Since I did that, my Microsoft Office 2007 has locked up completely, I thought I could fix the problem but uninstalling and reinstalling, but I can't even remove it, it says the file is corrupted. Anyway, the url you provided won't work for me either, up pops a page with huge black letters that says Bad Request. Any chance you can repost the url? Or anyone else have any ideas?

Back to Hardware Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums