General discussion

Locked

Systray network icon is missing

By mozbius ·
Hi everyone... I've got a problem here. My systray network connection icon is missing. I've had that problem a couple of times before and each time the only solution that I've found was to reinstall Windows from scratch. Everything that I've read yet on the net didn't work for me...

I don't know if this can help but I've just found out that the Hibernate mode might have something to do with the problem! Yesterday night I was working on the computer. Everything was fine then. So before going to bed since I wanted to pick up on what I was working the next day, I first disconnected from the internet (PPPoE) left my Dreamweaver window opened with IE opened and then went in hibernate mode.

This morning I've booted the computer up found everything the way it was before hibernating. I then tried to connect to internet and BOOM the icon wasn't showing up anymore!

Can somebody help out? The only way that I can disconnect from my hispeed now is by disconnecting the network cable from the PC. >:-(

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by docbob In reply to Systray network icon is m ...

I assume you are using XP (if n ot please advise). All I can suggest is go to network connections, right click on the connection you have and go to properties. There is a checkbox that says to show icon in notification area. You may try clicking that differnt from what it is (if off put on, if on, take it off, then OK it then go back and turn it on).

You can also enable and disable connection from the icon that youcright clicked on.

Bob M.

Collapse -

by mozbius In reply to

Yes I do use XP but unfortunately that solution that you've given doesn't work. I've found a workaround though... I looked around and found that I was lucky enough to have automatic restore point dating from previous day! :-) other than that registering net*.dll or playing with dcom... doesn't fix the problem.

Collapse -

by ghimpe-- In reply to Systray network icon is m ...

Also try this:

Go to Task Manager (Ctrl + Alt +Delete)

Under Processes tab click explorer.exe and then click End Process

Go to File --> New Task (Run..) click browse, go to /windows folder and select explorer.

Then pray that the network icon will apear

Since i installed SP2 i'm having problems loading all my systray icons, and by restarting explorer.exe corrects that problem. Maybe it will also help you.

GooD LucK

Collapse -

This solution also works with Vista

by reggy In reply to

This solution also works with Vista, all suits. You can also reactivate explorer.exe by just simply type "explorer.exe" in the "new task" field and execute it by clicking "OK". Wait a few seconds and the taskbar, systemtray and minimized open windows will re-appear.

The disappearance of the system tray icons often occurs after an Windows update and even won't re-appear after rebooting (for some weird reason I don't quite understand at this time). Updates are supposed to improve your system, but from time to time they merely screw things up (ie. the recent pre-vista-sp1-reboot-loop-update)

Collapse -

by _Christian_ In reply to Systray network icon is m ...

The answer 1 was coreect as far seelcting if you want it in the tray or not goes (both on W2k and XP)

BUT there is a glitch in both systems, which acts in such a way that now and then, ALL icons will vanish from the tray, and only reappear on first status change. If this is the case, the ONLY solution is a clean shut down and restart, so the hibernate mode will maintain the default (it is basically a memory dump).

On XP there is another possibility. XP has the nasty habit of hiding the tray icons which have not had a status change for a while. If this is the case, you will see an arrow on the left of the system tray. Clicking on it will allow you to see which tray icons have been hidden.
There should be a system option to disable this feature (Microsoft's Motto: "It is a feature, not a bug!).

Collapse -

by JonathanPDX In reply to Systray network icon is m ...

Seems that every manufacturer has a differing view on "sleep" and "hibernate." I don't trust either so I don't use them, there's just too many little quirks that pop up and disturb things. Is there a reason you need to shut off your connection overnight? If your security is up to date, it isn't really necessary. Or, if you're using a firewall such as ZoneAlarm, you can lock the connection while you're away. Just a thought.

Collapse -

by mozbius In reply to Systray network icon is m ...

Thanks for all your answers but none worked out for me. The problem here is not that the icon disapears because it's not being used (with the little arrow and all)... It's definately a bug in Windows XP. I've managed though to get the icon back by using a restore Point!

I do have ZoneAlarm and other stuff to protect the computer but still it can be quite annoying to not have the icon showing up to see if there's any activity on the connection when some stuff don't work properly.

I believe that there might be something in the registry that gets stuck somehow when that happens. Maybe I should do a backup of the registry and then go in Hibernate mode to see what has changed.

Collapse -

by lodrve In reply to Systray network icon is m ...

By default, the network icon found in the systray is set to not be seen. To enable this icon in your systray follow the below steps.

1. Right-click on the "My network Places" or "Network Neighborhood" icon on the desktop and click properties. If this icon is not available open "Network connections" from the Control Panel.
2. Within the network connections window, right-click on the network for which you wish to view the network icon for and click Properties. For example, right-click on "Local Area Connection" and click properties.
3. Finally, within the properties window, check the "Show icon in taskbar when connected" or "Show icon in notification area when connected" box at the bottom of the window
4. Click the "Ok" button.

Back to Desktop Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums