General discussion

Locked

TCP/IP not installed

By sia ·
Hi all

I have 2 computers Windows XPpro networked through a router to ntl set top box.
2 weeks go I installed software for Hand held PC/GPS
Few days ago for unknown reason my host computer crashed
I had to reinstall XP (I did not lose any file).
Now I can not go to internet or file transfer with second computer.
But Second computer can use the internet but can not see the host
The host has privet address of 169.254.53.168 and 255.255.0.0 and NO default gate way
And second computer 192.168.0.177 and 255.255.255.0 and default gate way 192.168.0.1
Now when I start the computer I get the message
?Mobile Devices Properties?
?TCP/IP network transport is not installed?
I tried repair, message said ?can not repair, see your ISB. Which I did).and they couldn?t help
I tried to make a new connection and that didn?t work.
Also all the connection are ok
Please be patient with me, I am newbie

Thanks in advance

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Winterfrost In reply to TCP/IP not installed

You can try resetting the TCP/IP stack. See this article: http://www.techbytes.ca/techbyte32.html

Collapse -

by sia In reply to TCP/IP not installed

sorry reseting di not work for me

Collapse -

by allthegoodnamesweregone In reply to TCP/IP not installed

follow instructions here to reinstall tcp/ip

http://support.microsoft.com/default.aspx?scid=kb;en-us;817571

Collapse -

by Toivo Talikka In reply to TCP/IP not installed

Addresses in the range 169.254.0.0 to 169.254.255.255 are used automatically by PCs when they by default get an IP address using DHCP, in this case from the router or your set top box. The router probably assigns IP addresses in the range where your second computer got its address 192.168.0.177.

You should be able to duplicate the settings in TCP/IP Properties from the second computer to the host computer, basically you only need 'Obtain an IP address automatically'. You can first give it a fixed IP address of 192.168.0.100, for arguments sake, and default gateway 192.168.0.1 and once that works, change it back to 'Obtain an IP address automatically'.

If you still cannot connect, check that the network cable is connected. Is there a light in the indicator on the router showing that the router sees the host computer? If there is no light, check if the indicator light next to the network port at the back of the PC is on and flashing occasionally. You may have a faulty cable, a faulty router port or a faulty network card or the network port on the motherboard is damaged. If that is the case, you can install a PCI network card.

Then you can swap the cables between the two PCs but make sure that the IP address of the host PC is not 169.254.x.x but set to 'Obtain an IP address automatically'.

Or are you using wireless connections? The message 'Mobile Devices Properties' seems to indicate that. If either WiFi or Bluetooth connection is set in the host PC as the primary method and it cannot find a transport or base station, you would get the same situation.

Go to the Network Connections and right click the connections you do not need and click 'Disable'. If you use cables to connect the PCs to the router, leave only the Local Area Connection enabled. You have to right click Local Area Connection and make sure it has the word 'Disable' at the top of the popup menu, not 'Enable'.

Collapse -

by Toivo Talikka In reply to

When setting the IP address manually, even though you can use 192.168.0.100 as the IP address of the host PC, the default gateway has to be exactly the same as the default gateway address in the PC that works because IP address of the default gateway must point to your router.

You can check it by pinging the gateway address from the PC that works (Start - Run - cmd - ping 192.168.0.1).

Does your router have an administrative interface? Point your browser from the PC that works to 192.168.0.1 and give it a go. The firewall settings in the router may block the host PC. This is the case if packets are only allowed from certain MAC addresses, which would explain why it does not communicate with your new network card.

You can find out the MAC address, or the Physical Address of the network card by typing ipconfig /all in the command window.

Collapse -

by jcreedon In reply to TCP/IP not installed

I ran into a similar problem not long ago. I googled the error message and found the following on Cnet. I downloaded the fix - ran it and everything worked.

JC
================================
Cnet Message:

I experienced a similar problem after removing NewDotNet. I think this was some sort of spyware. Anyway after removing it i experienced problems with my internet connection.i kept getting the message ''tcp/ip newtwork transport not installed''. I tried many different methods to fix this problem but nothing worked. In desperation i searched the internet to find a solution. I found a website that had a possible solution. i downloaded the software, followed the instructions and now my laptop is now connecting to the internet as normal. life is great again. the link to the website is

http://www.snapfiles.com/get/winsockxpfix.html

I hope this works for you.

Collapse -

by syates In reply to

That worked for me as well , many thanks. Problem is I don't know what is was that caused the TCP/IP stack to disappear in the first place. Either removing a "WiFi scanner" application or a registery cleanup

Collapse -

by gmdoran In reply to

i did a system restore and fixed the problem. i was then able to go back in and fix the other issues i was having which was not accessing other computer on home network. i utilized net use commands by mapping a drive.

Collapse -

Appreciation

by thoangh In reply to

Many Thanks, your tips so helpfull. Thank you

Collapse -

by fluidtech In reply to TCP/IP not installed

Shouldn't you just be able to set the TCP/IP to "Obtain an IP address automatically"?

Back to Software Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums