General discussion

Locked

TCP/IP not loading

By ninet4 ·
I have a WindowsNT Workstation named "Dual3". Having found that a user installed all kinds of screen savers and had been visitin porn sites during the night, I download and installed Lavasoft's adaware. Trying it install it, I ran into an error, the system was still running Service Pack 4.

So, I installed IE 6 and SP 6a, and did the whole reboot. Upon comming up, I received the following error.

"Initialization of the dynamic link library c:\winnt\system32\dhcpsvc.dll failed. The pricess is terminating abnormally."

Since the file name clearly states that it has something to do with DHCP, i changed Dual3 to static and assigned it an available IP address. Rebooted the computer, and it came up to the same point. Just now, I tried and was successful at pingin Dual3 by its hostname, which was resolved to the correct IP address. The shares on the computer are accessible, and it can access the shares on other computers. But certain network apps are not running properly, and I can't get connection on IE.

I have tried removing network completely to reload it, but run into and error every time I try to uninstall TCP/IP. I have also tried copying the dhcpsvc.dll from another computer that has the same setup. No dice.
Any help would be appreciated.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by jschein In reply to TCP/IP not loading

if you have fully ran adaware, re-installed sp6, reboot and still have issues, then hopefully you have an image handy. otherwise, it is time to backup pertinent data and reload that machine.

After some spyware or virii, there is no way of getting the machine back to normal.

Good luck.

Collapse -

by ninet4 In reply to

I will find an answer... there is always a fix.

Collapse -

by smadaras In reply to TCP/IP not loading

That is the DHCP client service dll, actually should be dhcpcsvc.dll. It really just requests an address from your DHCP server. After adding the static IP address, if you can't browse with IE or remotely access some resource on the box, you have to do 2 things.

First make sure the proper DNS server, either the local server forwarding to the internet or the actual DNS server from your ISP. This should resolve browsing.

Second make sure that the WINS server(s) have the new info for the static IP address you added. Delete any old entries for 'Dual3" and add the static entries manually.

If you don't want to get the error message any more, go into services--go to Properties under DHCP Client Service and change the startup to 'disabled'.

PS Get off of WinNT, 2000 is better, and XP is WAY better.

Collapse -

by ninet4 In reply to

LMAO at get off NT. I know that both 2000 and XP are better, I love XP. Have to run NT on these machines to support client software, so I am stuck. I have already disabled the DHCP service, my WINS and DNS is all good. Not that WINS has anything at all to do with browsing the internet. My DNS is set as my internal firewall intereface which forwards to my ISP DNS. I can ping the computer by hostname which means my WINS is working, and I can also reach other coputers from that one which further verifies WINS is working.

When I run IP config or any other IP program on Dual3, I get the error I stated above, despite the fact that I am not using DHCP anymore, and that I have set it to be disabled at startup.

Collapse -

by ninet4 In reply to TCP/IP not loading

I knew there would be a fix, and I found it. For those of you that run into this problem, try Micorsoft Knowledge Base article 151237. Has a list of registry values to delete. Did so, reinstalled networking, and then SP6a... Like a charm.

Collapse -

by ninet4 In reply to TCP/IP not loading

This question was closed by the author

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums