General discussion

Locked

TechRepublic web site does not work on Firefox - FOR SHAME!!

By glnz ·
Tags: Community
It is amazing how the entire TechRepublic website does not work well on Firefox with typical security. Even if I set my NoScript to permit all scripts on TechRepublic pages, many of TechRepublic's page features do not work. I must always reopen in IE.
For shame!

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

I wonder what browser I'm using.

by john.a.wills In reply to TechRepublic web site doe ...

I thought it was Firefox, but obviously I was mistaken.

Collapse -

Can you send me screenshots

by tcavadias Staff In reply to TechRepublic web site doe ...

of the issues you are seeing? As I use FF without issue, with and without NoScript, so I really would like to see them so I can get a bug filed.

Also I would need your OS.

Thanks!

You can email me here: tammy.cavadias@cbsinteractive.com

- Tammy Cavadias
Community and Member Service Manager
ZDNet, TechRepublic and Smartplanet

Collapse -

glnz

by glnz In reply to Can you send me screensho ...

Tammy - sent you two emails. It's Win XP Pro SP3 at work, on a Dell Optiplex 780 with 4GB RAM. Right now, I'm on IE. Techrepublic on Firefox is hopeless.

Collapse -

I haven't gotten TR to work consistently yet

by Slayer_ In reply to TechRepublic web site doe ...

I usually have to switch between chrome, ie and firefox depending on link.
It killed TR for me.

Also, the fact that blog posts no longer show in discussions.

Collapse -

So far no problem on my FF

by lancelot2002 In reply to TechRepublic web site doe ...

So far, I have not encounter any difficulties in using TR site with my FF version 28. By the way, I used to be a FF fans, but no longer.

Back to Community Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums