Question

Locked

Terminal Server User Access problem - Windows 2003

By ccarpenter ·
I have several Windows 2003 servers running as terminal servers. As near as I can determine, all are configured the same way. All have been running successfully for at least a couple of months (some longer). Today, we started getting the message:

"To log on to this remote computer, you must have Terminal Server User Access permissions on this computer. By default, members of the Remote Desktop Users group have these permissions. If you are not a member of the Remote Desktop Users Group or another group that has these permissions, or if the Remote Desktop User group does not have these permissions, you must be granted these permissions manually."

I've been all over this server, comparing to two others. "Allow logon through Terminal Services" has everyone listed. The Remote Desktop Users group is populated as well. I haven't found anything at Microsoft that covers this. Logon fails with both RDP from Windows XP workstation and the older mstsc client from Windows 2000 workstation.

Remote Desktop Users group does have Domain Users. RDP-tcp properties under the security tab shows that Remote Desktop Users have permissions.

The server is not a domain controller, nor are we running Active Directory.

Is there a feature that may have been turned on that would cause this?

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

No Active Directory

by pnb51 In reply to Terminal Server User Acce ...

Do the Users trying to access this Terminal Server actually have an account on this Server?

Otherwise, the everyone group will not give access to theses users.

Collapse -

Account on Server

by ccarpenter In reply to No Active Directory

Yes, they do. It's part of the same domain.

Collapse -

Me Too...

by daytech In reply to Terminal Server User Acce ...

I ran into this just within the last few days on logins which have worked for months. However, we do run active directory. I discovered the username field of the Remote Desktop Login Screen appended the TermServ Machine name before the username rather than the domain name. Changed the login to {Domain}/{Username} format and login went right through. Next login held these settings. May not fit your situation exactly but may give you a clue?

Collapse -

Not Me

by ccarpenter In reply to Me Too...

We saw that in the username field. If we tried to login with the machine name on it, it would tell us it couldn't login us in. Take the machine name out, and it would log us in but not allow access. In fact, we also noticed when viewing Terminal Server Manager that the account would show as Connected, not Active.

Collapse -

Problem Sort of Resolved

by ccarpenter In reply to Terminal Server User Acce ...

We have 'sort of' resolved the problem. Actually, the problem is fixed, at least for now, I just don't know how. I was at the point that I was going to reinstall the operating system, so I pulled the server out of the rack and brought it into my office and reconnected it to the network there (same network). For some reason, I tried it again and it worked. Don't know why. My guess is that it might have something to do with having two NICs on two different networks and the routing table got messed up. If it happens again, that's where I'll look. All the suggestions pertaining to permissions didn't apply as they were all set correctly.

Collapse -

Terminal Services Client 6.0 Update

by Lost in CQ In reply to Problem Sort of Resolved

Had this one as well, did a google on it, it's a known bug in the latest TS Client update, I found this page that seemed to have a handful of solutions http://blogs.msdn.com/ts/archive/2006/11/29/remote-desktop-connection-terminal-services-client-6-0-for-windows-xp-and-windows-server-2003-english-only-released.aspx

Hopefully MS will release a fix for some of these issues soon!

Collapse -

'Sort of' was accurate

by ccarpenter In reply to Problem Sort of Resolved

Turns out the only users that could logon were Domain Admin users. Had to add Domain Users to the Remote Desktop Users group on that TS to get it to allow regular users to logon. Suspected routing issue was a non-factor. Still don't understand why only this server.

Collapse -

Me too face this, since this morning on One PC ONLY.

by unni_kcpm In reply to 'Sort of' was accurate

Dear All

Me too face this issue ONLY A single PC. Is this problem due to expiry of CAL's or not having enough CAL's ? Suspect this !

Anybody helpful on this pls

Collapse -

Same problem different workaround

by matthew.savige In reply to Me too face this, since t ...

I had the same issue but found if you add the users directly into the permissions under Terminal Server Configuration it works. This isn't ideal though as it has the potential to get a bit messy admininistration wise later on.

I tried adding a new security group and attaching it to both user and TS Permissions and that didn't work either.

Collapse -

Issue Resolved

by masoodsharif In reply to Terminal Server User Acce ...

The same problem came to me.

This is a terminal server licensing problem.

I uninstalled and re-installed terminal server and terminal server licensing and then re-configure terminal server licensing.

be careful not to select 120 days licensing.
at server ip address type ip of your server.

Back to Networks Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums