The Client Could Not Connect to the Remote Computer

By dmthomson ·
We have a terminal server (Windows 2000) setup that is connected to a router which forwards RDP requests it receives to this server.

One of the network cards on the Terminal Server, failed, so I replaced it, and configured the IP settings the same as the failed card.

Now however, whenever a user outside of our network attempts to connect, they get the following error message:

"The client could not connect to the remote computer

Remote connections might not be enabled or the computer might be too busy to accept new connections"

I have tried changing the IP address of the server and forwarding it to that address, with no luck. I have restarted the router, to no avail, tried different cords (just in case) all to no avail.

Any suggestions would be greatly appreciated.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Check the NIC bindings

by lyallaust In reply to The Client Could Not Conn ...

Open the Terminal Services Configuration Manager (Start --> Control Panel --> Administrative Tools --> Terminal Services Configuration)
Select Connections on the left
Right Click on RDP on the right
Select properties
Change to the Network Adapter tab

You should see your current settings there, which may still be pointing to the old Network Interface Card (NIC).

Collapse -

Checked Bindings

by dmthomson In reply to Check the NIC bindings

It is currently set to "all network adapters configured with this protocol"

In the drop down box it has the new adapter listed and is set for unlimited connections. Should it be set specifically for the new card?

Collapse -

tcp filter

by mark In reply to The Client Could Not Conn ...

check the properties of the network connection. go into the tcp/ip and select advanced. On the options tab select properties and make sure the port is open.

Related Discussions

Related Forums