The directory service was unable to allocate a relative identifier

By bijusinbox ·
We are in the process of creating our AD DR env of our PROD env on a separate subnet as we don't want the DR env to talk to the PROD env.

PROD Env: Forest functional level is W2k3 and all DC's are w2k3 and are all Vmware VM's.

We have created a DR env on another subnet with similar umber of VM's for similar number of Dc's in the prod env.

Next, we restored the ntbackup of the DC in the prod env that had all the roles, except GC, on one of the VM's in the DR env.

Went into DSRM and restored the backup non-authoritatively.

Then, before rebooting, set the burflags to D4 to make it the AD DB authoritative.

Note: We have an internal policy here that specifically asks us to first do non-authoritative restore then use either ntdsutil or via burflags to set to Authoritative.

Rebooted this VM into normal mode. Then, went into ncpa.cpl to set the DR env IP address'. DNS was set to look at itself as this was the first DC in the domain.

Then, started DNS server and started Netlogon from paused state.

Created a new subnet for the site as the DR network is different compared to prod. Now, This first DC is functioning as expected.

Now, when I try to add a gives the following error towards the end of the dcpromo process:

"The directory service was unable to allocate a relative identifier"

I tried to first add the VM to the domain...but same error.

I have gone through the following MS articles to no use as this is a DR site with no connection to the Prod network.

KB's: 839879 822053

Would appreciate expert comments on how to proceed...

Thanks in advance.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Share your knowledge

Related Discussions

Related Forums