Question

Locked

The printer driver is unknown - NT4

By Lovs2look ·
This is the error that I get trying to install a HP laserjet onto a HP vectra NT4 box on our domain. In particular its a couple of laserjets, 3055 and 1300 models. Our workgroup 4100 installs OK, and a Lexmark Optra does too. But I just can't get the 3055 & 1300 to setup. I can get all the way thru the wixard when it says that the server doesn't have a suitable driver, do you want to insatll another? I go yes and point to the CD that came with the printer, specifically the NT4 driver and then I get the driver is unknown error. I successfully fixed this on one NT4 box when the spooler wasn't interacting with the desktop, but that is not the case on this PC. I even loaded another vectra with a fresh install of NT4, SP6a and updates and I get the same error. Boy it's bugging me! Can anyone help? Thanks if you can.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

This link may help

by Jacky Howe In reply to The printer driver is unk ...
Collapse -

Thanks 4 that

by Lovs2look In reply to This link may help

Didn't help tho'
Lanman is the only service listed

Collapse -

No Problems :)

by Jacky Howe In reply to Thanks 4 that

Did you ever get them to work. :)

Collapse -

I did, BUT...

by Lovs2look In reply to No Problems :)

but i've forgotton what I did! Now I have the same issue again, on a different printer/PC. Its a brand new HPLJ2014 and a Compaq Deskpro running NT4 SP6a. Laserjet has a jet direct card installed, and I have successfully installed it to our domain controller using the supplied CD - no worries.
I thought setting it up as local install initially, then after it's installed the driver, point it to the network location. I think that's what I did last time. This time it's not letting me.
I've tried local install and still get driver unknown error, network install - driver unknown, follow the wizard - unknown driver again...jeez this is pissing me off. Why hasn't HP fixed this yet?
Sorry about my curt reply yesterday but this is really frustrating me now.

Collapse -

Holy Crap! I found it!

by Lovs2look In reply to I did, BUT...

Whilst trawling google for answers I came across an article "Installing additional drivers on an older version of windows" by Bruce Sanderson. Essentially following these steps got me to where I needed to be...HooRay!
In a nut shell;
1. Install the printer locally to LPT1 using the native drivers. In my case NT4.
2. Delete this printer when finally setup. This just deletes the printer from LPT1, NOT the drivers.
3. Browse to the network location of the shared printer (in my case was attatched to our domain controller) right click and choose install. NOTE: It MUST be shared for this to work.
4. Wasn't sure if anything happened, but browse to printers and voila! there it is...test page prints OK, so all good now.
5. WRITE THIS DOWN!
P.S. I was logged on as the Administrator to the NT4 box. I had to supply a username/password to be able to browse the Domain Controller's printers, but I have this pwd, so no problems for me. See your network admin if you need to.

Keywords for others trying to find a solution:
Printer driver error. The print driver is unknown. Windows NT4.0.

Collapse -

It may come in handy

by Jacky Howe In reply to Holy Crap! I found it!

one day. Maybe not in the foreseeable future but I will keep it for reference. We don't get to many queries regarding NT4 these days. NT4 File Server was good in its day. I really enjoyed using it.

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums