toshiba not booting

By jeff rhodes ·
Toshiba satellite L550-1cc was shutdown successfully but now will not boot, power light comes on but will get no further than spinning HDD for about 20 seconds and then HDD stops power light on and nothing?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Could be a couple of things

by robo_dev In reply to toshiba not booting

On a laptop that won't boot, first thing would be to unplug/remove anything that can be removed. Battery, drives, memory, anything else plugged in. Sometimes a failed component can stop it from booting.

If possible, try a different external power supply as well.

If a laptop won't pass POST with all things removed, then there's not much more to do.

At that point it's either the motherboard, processor, or some issue like a display or backlight issue.

Collapse -

Reponse To Answer

by jeff rhodes In reply to Could be a couple of thin ...

Thanks robo_dev tried all that and have hooked up the HDD to my main computer and it seems ok can read the disk so have ruled that out. Very occasionally it will reach the screen Repair windows or start normally, which ever is selected it dies shortly after. My guess was much the same as yours, wondered if TechRepublic had done a tear down?

Many thanks

Collapse -

What i tell my customers to do

by OH Smeg Moderator In reply to toshiba not booting

Is remove the Power Lead and Notebook Battery and press the On Switch for 10 seconds. This discharges the capacitors on the M'Board, then plug the Battery and Power Lead back in and see if it starts now.

If it doesn't they need to get a Tech to look at it as there isn't much more that they could do. Mind you that cures 9 of of 10 issues with NB's not starting.


Collapse -

Reponse To Answer

by jeff rhodes In reply to What i tell my customers ...

Thanks Col will try that ,


Collapse -

No Boot toshiba

by pessimist In reply to toshiba not booting

Jeff I recently had a similar problem. After removing battery and still no boot ,yes, tested the HD, in an enclosure it was fine too. I replaced the MOBO, but also found that the ribbon cable connectors MIGHT be the problem. If these tiny ribbons get wiggled at all , or loosened, the contact points might not adequately touch the tiny wires. On the first cable from the switch, , lift the cable end latch - it swings up a bit. Gently pull out the cable and with a SHARP pair of scissors cut off about a 32 or a 1/64 of an inch. Insert fully into the slot of the cable destination , and hold in while closing the latch. Then, DON'T TOUCH AT ALL .See if that works !

Related Discussions

Related Forums