Question

Locked

Toshiba U205-S5034

By ku5165 ·
Hello everyone, i have a new problem ive had a toshbia u205-s5034 laptop for 1 year 2 month now....and the laptop started acting funny, first it would not charge when the power was on, so for 2 days i charged my batteries overnight while ordering a new charger, now it wont charge at all, the orange light that should come on for charging does not seem to show up, ive tried charging 3 different batteries with 2 different chargers, the laptop will only run off of ac power. It runs fine expect for it is not charging. I do know how to open the laptop however i could not find any problems with the laptop interior (ex burn out part or someting).
I do have access to a multimeter, if someone would show me how to test the charging circuit i would love to try and fix it, I have some minor skills in soldiering. Ive checked the charging plug, it seems to be ok...
Please help me out...cuz i have no way of using my laptop for its portability
I have checked the dc jack and it is fine...someone please be kind enough to help me
Thanks in advance
Ku

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Test this out..

Take out your battery.
Does your computer still work or can you switch it on without the battery in (make sure you have it connected to the electrics).
If it does then that takes out the guessing that it would be your motherboard.
Now (WARNING!! please disconnect your laptop from the mains) replace the battery, but this time use the battery until it is nearly exhausted (completely dead) then connect your computer/laptop to the mains.
Does your charging light come on?
If it does that means each time you fully charge the battery you must let it run right down to bare minimum before you start charging again.

Please post back if you have any more problems or questions.

Collapse -

didnt work

by ku5165 In reply to Test this out..

i tried that before, and again just to check for you, yet it did not work, the laptop runs fine off of the mains but does not want to charge the battery
thanks for your prompt reply

Collapse -

Another possibility is that the contacts to the battery are dirty

by OH Smeg In reply to Toshiba U205-S5034

Try removing the battery and cleaning the contacts on the battery & NB with either a soft rubber or a Alcohol Wipe.

If you know how to use the Multi Meter check for power at the Battery Connector on the NB with the mains adapter plugged in. If there is no voltage there on any of the pins the M'Board has suffered a failure of some description.

Col

Collapse -

cleaned contacts and checked using multimeter

by ku5165 In reply to Another possibility is th ...

The really wierd issue thats happening is somethign is triggering the laptop to not charge the battery, because using a multimeter i get volatage at the battery pins which means that it is sending power, however some system i not allowing it to charge the battery..i dunno wat it is....if i could find out how to fix that id be done..

Collapse -

Lithium Ion Charge-Latency could be the cause ...

by OldER Mycroft In reply to Toshiba U205-S5034

L-ion batteries are unfortunately no less exposed to charge-latency than their junior partners, the Nickel Cadmium family.

If you have been using your laptop for a long enough time, on battery power, BUT recharging the battery pack without fully discharging it first, the battery pack is now the victim of charge-latency.

Basically it assumes that the point at which it is charged, is the lowest end of it's discharge cycle, thereby limiting the range of service available from the battery.

Also, if you have been running the laptop on AC mains power for long periods of time, with the battery in place, you will have seriously inhibited it's capability to retain a charge at all.

Lithium Ion battery packs differ from Nickel Cadmium battery packs in one rather important respect - the Nickel Cadmium battery pack doesn't have it's charger electronics built-in to the battery pack itself. So all the time that a laptop is running on AC mains power with a Lithium Ion battery pack attached, it is not the motherboard that adjusts the flow of charging power to the battery, it is the fully-recharged battery pack that is desperately trying (and eventually failing) to stop the power from coming in.

This can be witnessed when running a laptop for a prolonged period, with battery attached, on AC mains power - the battery will heat up considerably!

Prolonged exposure to AC mains current will damage the Lithium Ion battery pack to the point that it will not accept a charge at all.


<Edited for clarity>

Collapse -

kinda maskes sense some clarification would be nice...

by ku5165 In reply to Lithium Ion Charge-Latenc ...

this makes sense kinda, the only problem that does not make sense is that i bought two new batteries which neither charged, is there a possibility that something in the batteries have to be reset so they can reaccept charge?

Collapse -

You really need to ask this of Toshiba

by OH Smeg In reply to kinda maskes sense some c ...

They know exactly what they have inside the Battery Pack. But it is possible that the spare batteries if left discharged for a long time have developed a Memory if you like and are no longer accepting a charge.

But the more likely thing is that while you have Voltage at the Pins on the NB you don't have enough Current to charge the Battery/s. Unfortunately this isn't something that can be checked with a Multi Meter but if there are 3 Batteries involved here all displaying the same way that is what I would expect to be happening.

Col

Collapse -

Makes Sense

by ku5165 In reply to You really need to ask th ...

Thanks for the info, you said that there might not be enough current(is the unit for that amperes?) shouldnt it be possible to check the current using a multimeter, ill check my multimeter later on today to check if it can do that...
Thanks very much for your info, if this bit helps, there was a power surge/sag before all of this wierd stuff happened (i just realized it because the other day the power went out at my cousins for 1 min)

Collapse -

Yes it is called Amps

by OH Smeg In reply to Makes Sense

But in this case it is a fraction of a Amp that needs to be measured and Multimeter's are just not accurate enough for this measurement. You need a dedicated Amp Meter to do this job with a very low range and without the reference voltage that the Multimeter's use.

Col

Collapse -

OH....

by ku5165 In reply to Yes it is called Amps

ahhh, well i guess that just leaves me to continue wondering what is wrong, i found someone with the same laptop and i plan on seeing if they wish to see if my battery charges in their laptop. Ill keep you posted

Back to Laptops Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums