Question

Locked

Trouble update BIOS via USB stick

By mkmwork ·
My laptop Dell X300 does not have a floppy drive. Dell bios utilities need a floppy disk to update. I use a bootable USB stick to try to flash the bios. After booting to dos promt I run the bios utility. After 72% I encounter the following error: "Cannot flash if memory Managers (..) present". Can anyone help me?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

You need to make that bootable, unless

by seanferd In reply to Trouble update BIOS via U ...

the instructions for the BIOS file indicate you can install it when windows is running. All older BIOS flashing always occurred with no OS loaded, but some more recent methods will flash BIOS from Windows.

So, if you cannot flash from Windows, it doesn't matter if you only have the CMD environment or the full GUI. You will need to boot from the BIOS flash setup on the USB stick.

Collapse -

You don't need bootable medium for Dell BIOS update

Just use your operating system, for example, if using Windows, use your web browser, go to Dell's web site and download the BIOS update to your desktop. The installer places an icon on the desktop, double click and let it run. Your computer will tell you to close open programs, etc, then will reboot to finish the installation.
If you're going to continue on the "hard way" with a bootable USB drive, you'll have to boot from it in some sort of "safe mode" with minimal drivers, then run the BIOS updater.

Collapse -

both bios utilities from Dell need a floppy

by mkmwork In reply to You don't need bootable m ...

BR112427.exe or X300_A10.exe are the bios utilities that I need.

BR112427.exe creates a bios image on a floppy disk.

X300_A10.exe is for a bootable floppy disk. After creating a bootable floppy, you can copy this file to the floppy. After booting to the command prompt you can execute this file. My laptop does not have a floppy drive. As I mention in my question it does not work via a bootable USB stick.

Collapse -

Have you tried CD?

by TobiF In reply to both bios utilities from ...

Do you have a CD-ROM in the computer?
Have you tried writing the floppy image to a CD?

Everybody else - Would one have to change anything in the image to make it work from a CD?

Collapse -

cannot put image on CD

by mkmwork In reply to Have you tried CD?

When executing the Bios utility (BR112427.exe) it searches automatically for a floppy drive. You do not get the opportunity to change the location. I even change the bootable USB drive letter to A:. It does not work.
I wonder why Dell do something like this.

Collapse -

Well I have just tried downloading the Hard Drive Version here

by OH Smeg In reply to Trouble update BIOS via U ...

http://support.us.dell.com/support/downloads/format.aspx?releaseid=R79464&c=us&l=en&cs=&s=gen

This unzipped to the Folder on the HDD and then tried to update the BIOS on my system. It seems to work from within Windows but you need the R79464.exe version.

Col

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums