Question

Locked

Trouble with USB devices

By psamulewicz ·
I am having trouble getting new USB devices working on my Toshiba Laptop. I am running windows XP. Older devices previously installed are working. However, when I tried loading a new external hard drive, new flash drive and new ipod, I get errors when loading. By checking the location where they are loading, the new harddrive goes to CD/DVD instead of disk drives and the flash drive and ipod go to other devices. Obviously, the USB driver must have been corrupted (I think?). Two other ipods and other flash drives and extrenal harddrives (that were previously installed) still work. Any suggestions how to solve this problem? Thanks in advance...

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

same problem here...

by shmooth In reply to Trouble with USB devices

my usb ports were fine for a few months, and then a couple of months of using my ipod all the ports went out. i can't use ipod, printer, external hard drive, or mouse.

nothing's worked yet, and i tried a lot of wacky solutions.

:)

microsoft sucks.

Collapse -

Have you found a solution? I have not yet...

by vferdman In reply to Trouble with USB devices

I am having same problems. Everything worked fine on my Toshiba Satellite A15 with Windows XP and then suddenly some USB devices stopped being recognized. Devices I installed and used before worked as usual, but for example I bought another thumb drive from the same manufacturer as the one I had, even the same size, but the ne w one would not get recognized by the laptop. The old one continued working fine. I am suspecting some sort of incompatibility of the windows update and Toshiba hardware. Toshiba probably needs to update the USB driver to work with the latest XP updates. I looked and looked, but since this laptop is relatively old, Toshiba has abandoned it and there is neither a BIOS update nor any driver update from them. If anyone knows the USB hardware in the machine, maybe it is possible to get some sort of third party driver that is more current. Please update this thread if anything comes up as ?I am at my wits end with this problem. I do not want to get a new machine, dread Vista and this laptop works just great for my needs, so I see no reason to trash it just because big corporations decided to abandon it.

Thanks!

--
Vladimir

Collapse -

Corrupt USB enumeration in your registry

by robo_dev In reply to Trouble with USB devices

(standard caution: backup hard drive/registry and make a backup copy of any registry keys you delete by exporting them to a file).

Basically it sounds like the

HKLM\SYSTEM\CurrentControlSet\Enum\USBSTOR

keys are hosed. If you delete the relevant keys, this is mostly the same as uninstalling the device in control panel.

The weird thing about USB is that registry entries are created for EACH physical port, so there's lots of these.

While the USB driver itself could be corrupted, it's more likely that you just need to do some registry cleanup.

Collapse -

Corrupt USB enumeration in your registry

by vferdman In reply to Corrupt USB enumeration i ...

I am sorry, I am a user, not much of windows registry expert, though I am an EE developing firmware, so I am not totally ignorant, only ignorant of windows internals'. I mostly code for embedded DSP systems.

Please explain like you would to a 5 year old. What do you mean by "hosed". Those keys are just registry entries. Why would they be hosed? I know I had a lot of trouble with a bunch of thumb drives, even exact same ones that work in my system (same size and manufacturer).

Also, there is another data point here. I just bought a Sansa View MP3 player that is flash based and by default it connects in MTP mode. Works fine like that. I can see it, drag and drop to it, etc. However, there is a way to put it into MSC (aka UMS) mode. When I do that I get the same song and dance as with other USB devices that are not recognized. A wizzard pops up and tries to find a driver, fails and the hardware does not work. I get a big yellow '?' in the device manager under "Mass-storage". I get the player back to MTP mode and everything is fine again. Not sure of this helps or confuses matters more. It may be (but I am not certain) that the UMS/MSC mode is simply not supported properly. This is XP Home Edition SP2 with latest MS updates. The laptop is Satellite A15-S1292.

A resolution of this would be of immense help!

TIA

Collapse -

WMP 10+, will cause the device to

by ComputerCookie In reply to Corrupt USB enumeration i ...

connect as MTP, if you want to revert to MSC/UMS your will need to format and reinstall XP and not allow update from WMP 9.

Note MTP is built-into Vista.

Also, I suggest you check out your manual and check the website for firmware updates, or go to WMP 11.

As far as other devices go, some more details would help!

Collapse -

RE: WMP 10+, will cause the device to

by vferdman In reply to WMP 10+, will cause the d ...

I have WMP 11. The music player will not get recognized in MSC/UMS mode, but works fine in MTP. I am not even sure what the two modes are. I wish there was only one mode, but with Microsoft around things will get complicated and not so backward compatible. I am thinking that with other devices not working that those devies are MSC/UMS devices and are not capable of MTP mode? They would be the older memory sticks, digital cameras, etc. I may be off on this, but I am reaching here. I had never had these problems with usb devices. Most of them just mounted up and worked. this has started happening a while back all of a sudden and I am not sure what the cause is.

--
V

Collapse -

This should point you in the right direction

by Jacky Howe In reply to Trouble with USB devices

Here is a link to a handy little tool. Save it to the desktop.

http://www.usbman.com/WebDrivers/Intel%20USB%20System%20Check/USBREADY.EXE

Using Intel USB System Check
After the download has completed, browse to the file usbready.exe and double-click it. A Welcome to Intel USB System Check message will appear on the screen.
Click Yes . The Intel USB System Check program will check the computer system for USB compatibility.

Computer systems with full USB support
If the computer system has everything required for USB to function correctly, a ?This system has full USB support? message window will be displayed. This message window has green squares with the word "YES" in them.

Computer systems without full USB support
If the computer system does not have everything required for USB to function correctly, a ?This system currently does not have full USB support? message window will be displayed. This message window has red squares with the word "NO" in them.
Click Details, and then read the following summaries that are displayed:
System Software Support
System Hardware Support
USB Driver Support

http://www.usbman.com/winxpusbguide.htm


USB Device Stops Working or Won't Resume

WinXP by Default turns off USB Root Hubs to Conserve Power causing some devices not to resume correctly after Windows resumes from sleep, hibernation or computer inactivity.

In the Device Manager, Universal Serial Bus Controllers, USB Root Hub, Power Management. Uncheck the Allow the computer to turn off this device to save power. Uncheck all boxes on all root hubs.

Resart the PC.

Back to Hardware Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums