Question

Trying to install Kompozer on Linux Mint v19

By jim_trahan ·
Tags: Software, Linux
I'm not sure if this is the right forum area for this, but if not, perhaps someone here would be kind enough to direct me to the correct place. I'm a Linux newbie, who just recently installed Linux Mint 19 to dual boot with Windows 10. I've been using Windows for many years, but thought I would try Linux for a change. I do some web design, have been using Kompozer in Windows, and would like to install it in the Linux partition, but have been having great difficulty doing so. I have found, downloaded and extracted the Linux tarball, but can't seem to get any further with it. I've tried all the suggestions in the Linux forums without success. Kompozer simply does not appear in any of the software packages, and I have no idea how to get it to make an appearance. This is about the only thing that prevents me from using Linux exclusively. Thanks in advance for any help!
8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Hi Jim,

by wizard57m-cnet Moderator In reply to Trying to install Kompoze ...

I don't have any experience with Linux Mint, but have used Kompozer in both Windows XP and in a smalll Slackware based Linux distro called Slax, version 7.0.5, and in Slax you had to install from the repository, unless you knew real well what you were doing. I suspect something similar is happening to you with Mint. So, check with the Mint repositories and see if a pre-made "package" is there for you to install using I think apt get?? With a tarball you sometimes have to use like a gcc compiler at command line by invoking the make commands...not extremely difficult, but can be a tad intimidating for a new Linux user (shucks, it can still give me hives, lol).. Mint is based on Debian/Ubuntu, so I feel confident you can find Kompozer in the repositories.
Good luck,
Wiz

Collapse -

Tried that

by jim_trahan In reply to Hi Jim,

Thanks for your response. I did look in the available software packages (Is that what you mean by repositories?) and Kompozer was nowhere to be found. I also tried following instructions I found on linux forums for using the apt-get command sequence in terminal, and got an error message saying the requested file was not found. Is it possible the instructions I found may have left out a step or two I wonder?

Collapse -

I wonder...

by jim_trahan In reply to Tried that

Could it be possible that since Kompozer development was stopped some time ago, it was removed from the repositories at some point?

Collapse -

It's possible, since Kompozer is older,

by wizard57m-cnet Moderator In reply to I wonder...

not updated since like 2010 I think. Anyway, found a couple of info souirces that may be helpful, the first details how to install the library files using commandline in a terminal...
https://askubuntu.com/questions/832913/unable-to-install-kompozer-in-ubuntu-16-04
I would try the instructions for later ubuntu.

The second offers an "install now" button, which would be nice if it grabbed all library dependencies at same time, so it may be a simpler method...
https://linuxappfinder.com/package/kompozer

Maybe one of these tips will be successful! If I run across anything else, will let you know.
Wiz

Collapse -

Informative

by John Cater In reply to It's possible, since Komp ...

Thank you for sharing this great and informative post, it really helped me

Collapse -

It Worked!

by jim_trahan In reply to It's possible, since Komp ...

The "Install now" button returned a "Package not found" error, but the command line terminal option worked without a hitch. THANK YOU! :-)

Collapse -

You're welcome!

by wizard57m-cnet Moderator In reply to It Worked!

Glad to have been of assistance. I'm posting this using a small Slackware distro called Slacko Puppy, this one is version 7 RC 3, with Palemoon for a browser! Lots of packages in slackware and its derivatives require some hands on work to get installed, especially tracking down missing dependencies, remember "DLL heXX" in Win9X? LOL, anyway, glad to help!
Wiz

Collapse -

Yup I remember!

by jim_trahan In reply to You're welcome!

LOL I cut my geek teeth on DOS 6.22 and Win 3.11. Got my A+ cert on the Windows 98 track in Feb 2000. Yup I do remember the DLL 773H (read it upside down) very well. I never was much thrilled with using the command line, so waited many years before finally plunging into the Linux waters. With all the advances made with user friendliness in the Linux GUI experience, and all the backstepping in user friendliness with the latest Windows releases, I just recently decided to give it another try. Mint looks very promising for acceptance by the average user.

Back to Linux Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums