Question

Locked

TSST corp DVD+-RW TS-H553A help, please

By sorata_yuy ·
My TSST corp DVD+-RW TS-H553A has stopped opening, either by pressing the button on the front of the tower, or by using the right-clicked 'eject' command in MyComputer. It just started this today, and nothing has been done to it to cause this. I've had the computer for two years now. Any advice if I should try to salvage it/fix it somehow/just forget it and replace it with a newer drive?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

It will probably be cheaper for you to buy a new Drive

by OH Smeg In reply to TSST corp DVD+-RW TS-H553 ...

And fit it than to attempt to try to repair the one in there. However there should be a small hole in the front cover of the Drive which you can insert a Paper Clip straighten out into and release the Draw so you can pull it open.

Look toward the front and see if there is a small Rubber Belt on the Idler Wheels. This may have broken, stretched or just worked it's way off the Idler wheels.

If it has come off you could try refitting it but if it needs replacing you will find that it is cheaper to replace the Drive. These Dual Layer DVD Dual Format Burners are very cheap now and are not economical to repair.

Col

Collapse -

Guess I'll be shelling out some money after the holidays, then.

by sorata_yuy In reply to It will probably be cheap ...

Thanks. Sadly, there's no such hole in the front of this one(just checked again), so I'd say I'm well and truly borked as far as that goes. It is definitely helpful to know this know, though, so thanks again! =)

Collapse -

Your Welcome

by OH Smeg In reply to Guess I'll be shelling ou ...

Glad I could be of some small assistance.

Sometimes there is a hole or cutout in the Drawer that you can use to open the Drive manually or in the case of the Optical Drive Types that have a Flap you need to pull the flap down by looping the paper clip behind it and twisting on the hinge. Then holding the flap open you need to push the Bar that goes across the front of the drive under the tray back slightly to unlock the drawer so you can pull it open.

Though now as I only use Sony Optical Drives because they are just easier to open when they go wrong.

Col

Collapse -

few things

by .Martin. In reply to TSST corp DVD+-RW TS-H553 ...

obviously it is working, as it is seen by windows.

have to ask, when you do press the open button, does it make a noise like it is trying to open? i.e., a motor whizzing sound?

try getting a paperclip and pushing it into the hole on the drive, this should open the drive, try seeing if there is anything that does not look right in the drive.

Collapse -

i'm having the same problem

by naebeth In reply to few things

with the same drive model. burned a few CDs, everything was fine. the last one i attempted finished the writing process as soon as it started, but Windows thinks it worked perfectly and is listing the files on the disc that should be. yet it won't open, even if i push the paperclip into the hole. and i did poke quite hard, which resulted in me being very surprised when the "wall" i felt moved and then pushed my paperclip back out again. still no opening.
so i tried disabling and enabling the drive in Device Manager, as this fixed the problem for the optical drive on my last computer. that doesn't help either. the CD is still in there, so whenever it decided to work i get iTunes asking me if i want to import the tracks, really quite annoying.

PLEASE HELP!

**edit**
got it to open by repeatedly jamming the paperclip into the hole as hard as i can. press the button and it closes. press the button and it doesn't open.
i had a look inside and no belts appear to have come off any wheels, as someone else suggested. what the **** is going on with my drive?!

Collapse -

Check the edges around the tray

by IC-IT In reply to i'm having the same probl ...

I have had to pry a few open that had small signs of residual sticky material. It had effectivly glued it shut.

Collapse -

i already tried

by naebeth In reply to Check the edges around th ...

to pry it open. didn't go well, the plastic just twisted and now has a dent in from my penknife.

all is fine now though, as its working perfectly fine. didn't do anything to it, it just worked when i turned my PC on. weird.

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Forums