Question

Locked

UltraVNC setup

By mdmustafa ·
Hi All.

I am unable to make a remote connection to a computer on a LAN using UltraVNC. When I connect using UltraVNC Viewer to the remote computer I am getting a message "Failed to connect to Server" or Could not find Server address. The following is my configuration :

PC1

Hostname : PC001
Workgroup : MSHOME
IP address : 192.168.x.x (given by d-link router)

No-Ip Client running on this PC & set to update host every 5-minutes

PC2

Hostname : PC002
Workgroup : MSHOME
IP address : 192.168.x.x (given by d-link router)

Speedstream DSL modem in Bridge Mode

D-link Router configured as below:

1. PPPoE configured for WAN with "Connect on
Demand" option

2. Virtual Server configured with ports
forwarded as below :

UVNC1 5900 5900 192.168.1.102
UVNC2 5800 5800 192.168.1.102
UVNC2 5901 5901 192.168.1.103
UVNC2 5801 5801 192.168.1.103

These ports are set to be available always.

UltraVNC is working fine inside the LAN.

Am I doing something wrong or is it a problem with the dynamic IP.

Please reply as soon as possible.

Thanks.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Connection

by Toivo Talikka In reply to UltraVNC setup

If the no-ip client contacts the dynamic dns host every 5 minutes to update your address, the chances are that when you check the address from your dynamic dns provider, the address is obsolete.

"Connect on demand" means that the DSL modem will connect to the ISP only when activity is detected from inside your LAN. If you select "Keep Alive" instead, the connection will stay up and your external (public) IP address will stay the same most of the time.

Collapse -

UltraVNC Connection

by mdmustafa In reply to Connection

Thanks for the quick reply.

A further description of the UltraVNC setup is as given below:

There are two options in the D-link Router WAN connection setup one of which is Connect on Demand & the other is "Always ON". The DSL modem was setup in Bridge Mode for the UltraVNC to work. Does "Keep Alive" mean same as Always On in a D-link router ?

Also do I have to add the Clients which are trying to access the computer from outside to the UltraVNC Server running on the computer ?
The UltraVNC Server is running as a system Service in Win XP.

Here is how I try to connect remotely to the UltraVNC Server :

In the UltraVNC Viewer I type in the no-ip host for example "dynip.no-ip.com :: 5900" without the quotes. After a delay I get the message Failed to connect to Server.

Also I want to manage the Router remotely to make changes to the setup for UltraVNC & I am unable to to connect to the router remotely even after I enabled remote management by giving the IP Address of the computer connected to the router & specified the port as 8080.In the web browser I type in the following to access the router setup

http://192.168.1.2:8080


I appreciate the help.

Thanks.

Collapse -

A couple of things

by Toivo Talikka In reply to UltraVNC Connection

'Always On' means the same as 'Keep Alive'.

The address in the viewer is the dynamic host domain name given to you by no-ip, or the corresponding IP address. If the VNC port is different from the default 0 (translated by the viewer to 5900), for example 1 (translates into 5901), you put one colon and 1. If you want to use the full port number, use two colons instead.

You can the IP addresses of clients to the VNC server only for outgoing connections (from your LAN to the public internet) if the hosts are already running vncviewer in listen mode. I have never used that option.

You must make sure that you have set the default password which takes effect if you have logged out from the PC host. Otherwise you cannot connect to the login screen to send Ctrl-Alt-Del and login to the PC if you logged out or if you want to restart the PC remotely.

Allowing remote management to the router may open a security hole. If you want to have the remote management option during the initial testing, you need to follow the instructions in the D-Link manual.

Note that the public IP address of the computer that you are going to use to do remote management across the net, connecting to your public IP address has to be recorded in the address field.

I had a quick look at the user manual for DI-604 and found the following instruction possibly misleading: "In the IP Address field type in the public IP address you wish to manage the router". What the technical author wanted to say is "the public IP address you wish to manage the router from".

Therefore, if are at work and the public IP address of your employer's internet connection is 123.45.67.8, you must have entered this address to your D-Link settings when allowing the remote management. Never leave the asterisk in the IP address field, which would allow anyone to connect. If the public IP address of your home network is 234.56.78.9, you point your vncviewer from your place of work to 234.56.78.9, or 234.56.78.9::5900. If you want to manage your router remotely, you point your browser to http://234.56.78.9:8080.

Remember to change the default passwords for Remote Management, and limit the use of this facility for troubleshooting only. You should also use a strong password for VNC.

Collapse -

UltraVNC troubleshooting

by mdmustafa In reply to A couple of things

Thanks for the quick & valuable guidance in UltraVNC troubleshooting. I will try it out.

Regards.

Collapse -

you need to add 5500

by dier02 In reply to UltraVNC setup

you need to add port 5500 so your listen port server is 5500 and your listen port viewer is 5901

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums