General discussion

Locked

Unable to add printer.

By saihib ·
I'm running XP Pro on an Athlon XP box. The computer is connected to a LAN but is not a member of the domain. I have access to network resources though I always have to supply a username and password to get it. Recently,in Start/Settings/Printers and Faxes, all my installed printers disappeared. The funny thing is that I can still print to the printer that had previously been designated as the default printer. What's pissing me off is that I am unable to add new printers. In Printers and Faxes, when I click Add Printer, nothing happens. No error messages, nothing. The wizard just does not run. I feel I need to mention that I just added a Canopus DVStorm2 capture card to my machine and the software that came with it has slowed my bootup time somewhat. Other than that nothing else has changed. Since it has been some time since I tried to add a new printer I'm not sure if the new software is the culprit. Microsoft's KB has been close, but no cigar. Anyone got a thought?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Comments

Collapse -

by Curacao_Dejavu In reply to Unable to add printer.

1: scan for viri, i know for sure that there was a virus a while back that infected the rpc and spooler services.
Also re-install sp1 of winxp.

Leopold

Collapse -

by friends In reply to Unable to add printer.

sounds like your Add Printer function has been disabled by your Administrator or been hijacked by website.

All you need to do is to use software to "enable" it back for that particular function.
Either one will work... check out WinBoost or WinForcer !

I'm still figuring out how to make it "disabled" for that Printer And Faxes function in Windows Registry without the aid of software.

Collapse -

by w2ktechman In reply to Unable to add printer.

You can check the group policies. Look under
user config -- admin templates -- control panel -- printers. There is an option to not allow printers to be installed. There is also a policy to disallow the computer from browsing the network for printers.
I dont know where in the registry to check for this, but I would apply the policy (even to prevent, if so then reapply to allow) to make the registry updates.

Collapse -

by saihib In reply to Unable to add printer.

None of the answers below provided a fix. Any other suggestions?

Collapse -

by tpanc513 In reply to Unable to add printer.

I had the same issue but went to Microsoft to resolve it - here's what they suggest:

Step 1
Test the issue using command

1. Click Start, and then click Run.
2. In the Open box, type "Rundll32.exe printui.dll, PrintUIEntry /il" (without the quotation marks, you may copy the above line and paste it to the Run box to execute it), and then click OK.
3. Can Add Printer Wizard be launched?

If it can be launched, the original issue can occur if third-party or earlier versions of dynamic-link library (.dll) files are located in both the C:\Windows folder and the System32 directory. If .dll files are located in the C:\Windows folder and the System32 directory, the printer subsystem does not function correctly. Step 2 should solve the issue.

Step 2
IMPORTANT: Any existing .dll files within the C:\Windows folder may have been added by an improper Windows XP installation or a third-party program. Microsoft strongly recommends you back up your system before renaming or removing any files from within the Windows directory structure. Renaming or removing these files may disable other installed programs or otherwise cause those programs to fail.

To troubleshoot this issue, boot into Safe Mode and rename all .dll files in C:\Windows folder except for:

Twain.dll
Twain_32.dll
Vmmreg32.dll

NOTE: All other .dll files may have been added by an improper installation or a third-party program. If you rename the files, you may disable that program.

After making this change, restart the computer to test this issue. If the issue is not resolved, please rename the files back.

This worked for me - hopefully it will work for you.

Collapse -

by glyall In reply to Unable to add printer.

your are having problems with the printer spooler.

to open the services
click startup then run enter services.msc
this open the services panel
select Print Spooler
Stop the services then Start the services
click OK to close the Print Spooler and close Services.

Opern your Printers and Faxes
You should see your prinerss.

Good Luck

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums