Question

Locked

Unable to connect to printer published in AD2003

By Scott_nightingale_2k ·
Hi,

Have a weird issue of which i can't find any technical posts for. I have published a couple of printers (in AD2003) on a satellite site which has it's own print server, but no local DNS/AD replica. Resolution is done via a WAN connection to the main AD controller. Print port resolution is done via DNS and clients on this remote network can resolve the printers via pinging the DNS name (as can the print server). The problems start when you try and browse to the printer through the domain, you find the site, printer and then try and connect to the printer you desire you get this error " Windows cannot connect to the printer. Either the name was typed incorrectly, or the specified printer has lost its connection to the server".. standard error message stuff. If you type the path in \\server\printer it works fine. I have exported the configuration from AD to a text file and compared this to a working printer on another site, no obvious difference in the configuration. The only thing which is different is the absence of a local DNS/AD replica, has anyone else seen this?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Possible fix for AD Publishing

by crobinson In reply to Unable to connect to prin ...

The error you reported - connecting to published printers was giving an error "windows cannot connect to the printer. either the printer name was typed incorrectly" was due to a CNAME record for the server in question pointing to a nonexistant server and no host(a) record for the print server. I discovered it when pinging the print server; it would not resolve to the FQDN. Once I removed the CNAME record the printers would connect correctly.

Collapse -

I wonder

I wonder if the issue may be related to NetBIOS name resolution: ever tried to verify if the DC can resolve the printer server by using its hostname (instead of FQDN)?

Collapse -

In my case...

by crobinson In reply to I wonder

I was able to resolve the hostname but not the FQDN. NETBIOS resolution was set to use DHCP settings and we ot publish NETBIOS settings in DHCP as 046 WINS/NBT Node type as 0x8

Collapse -

AD 2003 add printer fix for us.

by mruxsaksriskul In reply to In my case...

Hey,
Hope this makes sense. We were having the same issue and the resolution I found was to create a subnet under Active Directory Sites and Services matching our topology then I associated with our site. Ours was simple enough we only have one subnet for our entire network. This changes can be made live it didn?t affect anything from what I could tell. It did take a while for the info to replicate before the clients could transcend the AD topology.
You can find a helpful link here at expert?s exchange
http://www.experts-exchange.com/Hardware/Peripherals/Printers_Scanners/Q_22603791.html#a19207617
The other thing I did was to edit the local policy on our one printer server it hosts about (20printers). The change made was enabling the ?Check published state? and setting it to check at 1hr intervals. You can get to the local policy by:
Go to run type ?gpedit.msc?
Under Computer Configuration expand Administrative Templates
Then explain Printers and enable the policy ?Check published state?.

The problem I think we had is our printers are on the 192.168.0 subnet and the workstations are on 192.168.1 I?m not sure when it broke but this fixed it for us. I believe client machines use the AD sites and subnets to navigate to the printer via the right subnet. Which is outside of DNS which is why we could add the printer any other way i.e. \\servername\printer or \\xxx.xxx.xxx.xxx\printer out side of AD.
Hope this helps!
Thanks,
Michael
?Freely you have received, freely give.?

Collapse -

I'd go with Mruxsaksriskul suggested.

by CG IT In reply to AD 2003 add printer fix f ...

When you have sites they need to be setup in AD Sites And Servcies and as mruxsaksriskul mentions, the subnet on the site is put in. That was AD knows that the published printer is associated with that site.

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums