Question

Unable to connect two computers on different networks, works on same

By java_man ·
Hi all,

So I'm trying to netplay with a friend in a different city using an emulator. The two emulators we've tried using to connect to one another are Kega Fusion and Zsnes. So far, we've been unsuccessful.

I'm aware of port forwarding and setting up a Static IP. For the sake of practicality in testing, I'm attempting to connect my Acer notebook to my Dell XPS, both of which are on the same network - my wireless connection which I use to connect to the internet. I've designated the Dell as the host and the Acer as the client.

Here's the thing: the applications connect successfully in both emulators when I try to connect the Acer to the DELL, as long as both are in the same network. However, if I disconnect the Acer from the wireless service of my modem/router, and instead connect the Acer to my phone's mobile data and mobile hotspot, it fails to connect. I've ensured firewalls are disabled for the emulators on both devices, and since they connect when they're on the same network, I assume firewall issues can be ruled out.

This leaves port-forwarding and using a static IP. I've been able to setup a static IP: in IpV4 properties under the control panel, I've used the "Use the following:" option (not "Obtain automatically) and set the IP as the same one as my private IP except added 10 to the last two digits (0.12 originally, 0.22 as static), as well us setup the DNS numbers, subnet mask etc. I assume the setup is correct because I'm able to connect to the internet with the static IP.

In Kega Fusion, if I supply the Acer the 0.22 IP and use that to connect to the Dell, it again connects successfully but only if the Acer is again on the same network as the Dell. If I test it with the mobile hotspot, it doesn't connect.

I have attempted to port forward and ensured the correct ports are selected, with UDP/TCP selected, and the Static IP entered as the IP to forward. However, I'm still not able to connect. I have a public IP as well which I'm not sure if it will come into play somehow.

Based on the above, would it be possible to provide some solutions? Its strange for it to work normally on the same network, but not work when its on the phone's internet network (i.e. two different networks). Please note that even with the above things done, I've tested again with my friend and it still doesn't work, so I'm fairly certain there's no difference between using a phone's internet network and a standard ISP-provided service.

Modem/router is a SmartRG 804n
Thread display: Collapse - | Expand +

All Answers

Share your knowledge

Related Discussions

Related Forums