Question

Locked

Unable to format Pen Drive

By frawser7917 ·
I have a kingston 32GB pen drive. When I was formatting the pen drive, unexpectedly i clicked cancel while the format was on process. Now the pen drive is not working and I am not able to format as well. I tried formatting with hp disk storage format tool but no use.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

A couple of thoughts...

by TobiF In reply to Unable to format Pen Driv ...

I take for granted you're using some more or less recent version of Windows.

1. First, I'd try diskmgmt.msc to format it.

2. If that doesn't work, then try, <i>with the drive mounted in a USB slot</i> to uninstall it in the hardware management part of your control panel. Afterwards, pull the drive out and mount again. This should force Windows to try again "from scratch".

3. If this all fails, I suggest you head to http://www.kingston.com/support/USBFLASHDRIVES/default.asp and click through to email Kingston's support people.

Finally, please post back. It would be interesting to know what helped, if any.

Good luck!

Collapse -

i tried to format it using diskmgmt.msc but still not working

by frawser7917 In reply to A couple of thoughts...

s am using windows7.

i tried to format it using diskmgmt.msc but still not working

also tried to start from scratch but no use

Collapse -

Have you looked on the Kingston Site for Format Programs

by OH Smeg In reply to i tried to format it usin ...

Quite often what is listed as the size and what you get can be two different things.

Quite often with Memory Sticks a Large Size is brought about by using a Compression Utility and you need to use the Makers Formating Utility to get the unit to work again.

Col

Collapse -

No programs available

by frawser7917 In reply to Have you looked on the Ki ...

The pen drive is transcend made not Kingston. Sorry for the wrong information. I checked in transcend website. No programs available. The file system shows RAW.

Collapse -

Well in that case

by OH Smeg In reply to No programs available

You need to contact the Maker for a solution here. It may be as simple as returning it for Replacement if it's Under Warranty. Of course it may also be as simple as turfing it into the Rubbish and buying another one.

Col

Collapse -

I ran into an issue with a Verbatim drive Col....

by Darryl~ Moderator In reply to Well in that case

It was also a fairly large USB thumb drive (16 GB).

I had tried the HP utility & few other things to no avail...it seems the larger drives need specific software....Verbatim uses V-Safe 100 to format & also has a utility to password a portion of the drive....it might be worth a try.

What's your thoughts on it? the link to download it is below.

http://www.verbatim.com/support/support-article.cfm?cat=14&pid=5451&support_id=2BDCD814-5056-B854-C75879C877B433B8&supportType=Download

Collapse -

Not something that I have noticed Darryl

by OH Smeg In reply to I ran into an issue with ...

I've been using 16 & 32 GIG Corsair Thumb Drives for a while now without any issues.

Maybe with the cheaper ones there may be issues but nothing that I've personally seen.

I'll however give the Verbatim a go and see what it works like. :0

Col

Collapse -

Yes, they have online recovery tools.

by seanferd In reply to No programs available

http://www.transcendusa.com/Support/DLCenter/index.asp?LangNo=0&Func1No=11&Func2No=182

Probably this one:
http://www.transcendusa.com/Products/online_recovery_1.asp

Further, you can contact tech support there or use the forum.

Back to Hardware Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums