Question

Locked

Unable to reset RDP session

By mhaffendi ·
Hello,
I am having problem with my Windows Storage Server 2003 R2. Currently there is one id (user A) that is logged in at the server console. The account has locked the console and I am unable to unlock it because when I press Ctrl - Alt - Del and nothing happens at the login screen. The weird thing is the
mouse is moving and I am able to press the NumLock key without any problem (this eliminate the possibility that the keyboard or mouse are not working).

To logoff user A, I remote desktop to the server and tried logging off user A using tsadmin. However I encounter error "Session (id 0) reset failed (error 31 - a device attached to the system is not functioning)". I tried to reset user A using Reset command also and that doesn't work. Anybody knows how to solve this issue?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try RDPing to the console session.

by bart777 In reply to Unable to reset RDP sessi ...

Use the following command to get there.

mstsc /v:servername /console

Hopefully this will boot the other sesion off of the machine.

Collapse -

mstsc /v:servername /console does not boot off other session

by mhaffendi In reply to Try RDPing to the console ...

Hi bart777,
I have tried the method but it seems not working. When I use mstsc /v:servername /console, I am able to see the login screen. After I enter my username & password, it prompted me whether I want to logoff the current user. Once I confirm yes, it shows as logging off the current user and closed my RDP session. When I tried RDP back, the previous user is still not logged off. Do you have any other suggestions?

Collapse -

The bag is empty

by bart777 In reply to mstsc /v:servername /cons ...

Well almost...
The only other thing I can think of is to log into another terminal server session and open the task manager. Find the winlogon task that is tied to that user session and kill it if you can.

However the best way at thi point would be to boot the box. If you can get a timeframe that will not affect the users too much. Just power it down and bring it back up. That error about a device not working is probely what's hosing this process up.

Collapse -

Terminal Services Manager

by Bizzo In reply to Unable to reset RDP sessi ...

You could try going into Terminal Services Manager and seeing who is logged into the console on that machine. From there you should be able to either log off, disconnect, or reset that session.

Failing that, get the user who has this session open to log back on to the server and log off properly.

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums