General discussion

Locked

Unable to run Task Scheduler

By lbarcena ·
We were using a standalone WinNT4 server with a running Task Scheduler. When we upgraded it to Win2000 SP3, the task scheduler no longer runs. When I tried to run a scheduled task, I got a message, "The service is currently stopped..." and asked to run it. When I clicked "Yes" I got a message "Unable to run the service". When I checked the Services, I couldn't find the Task Scheduler. How do I re-install it?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Unable to run Task Scheduler

by dbesenho In reply to Unable to run Task Schedu ...

Some things to try: did you check the system32 directory to see if the mstask.exe is present? If so, try and launch it from there (maybe that will put it back to services list). also check dependent service to see if that is running (rpc service). If mstask.exe is gone from hd, you may be able to install it from mmc console. Or, check registry and see if it exists in hklm/system/controlset001 or 002 -- if so you may be able to copy the key and drop it into current control set. Last, try re-running win2k setup to replace missing settings. Hope any of that helps!

Collapse -

Unable to run Task Scheduler

by lbarcena In reply to Unable to run Task Schedu ...

Sorry, I thought my comment before were registered. I'm writing it again:
Thanks for the answers, but I'm afraid none of the above worked. Mstask is indeed present but launching it gave me an error that it should be run only from task scheduler. Other dependent services (rpc) is also present, and I tweeked the registry as prescribed. None of them worked. Lastly, even re-running win2k didn't work (I might have missed an important non-default step in re-installing win2K server)

Back to Windows Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums