General discussion

Locked

Unable to set page file

By whd ·
I have a computer that has WinXP SP2 installed. It is normally connected to a college network, right now it is not connected to anything. When the computer boots up it gives you a virtual memory error box that says the page file is set to 0, and windows will set a custom page file size. when you go to change the page file size it shows in the dialog box that it changed and prompts you to restart. When you restart you get the same message all over again. I ran Norton A/V and didn't find anything. I tried setting the page file to 4 times the suggested amount, but that didn't do anything. The computer only has one hd so I couldn't relocate the pagefile. I checked the users priveleges to make sure they were an admin, nothing. I checked the system account to make sure it had priveledges to change the page file, which it did. I logged in as the administrator and changed the page file, but still no luck. I ran "msconfig" to disable all startup items, disabled all non-microsoft services, and then restarted the system, but no change. I also booted into safe-mode and tried to set the page file, but no luck. Can anyone here help me, please?

This conversation is currently closed to new comments.

16 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by jschein In reply to Unable to set page file

Slave that drive off of a windows 2k machine.

Explore the root and delete the page file.

Re-install drive and page file should auto-recreate.

Collapse -

by whd In reply to

Poster rated this answer.
I don't currently have an extra hd handy nor an extra copy of W2K just lying around. Will try this if nothing else works.

Collapse -

by BFilmFan In reply to Unable to set page file

While you did run Norton's, I did not see a statement that you ran a search for any malware which might be operating. College networks are infamous hotbeds of malware, trojans and worms.

Some things to check:

How much disk space is free on the hard disk? There may not be enough or any free space on the drive to create a swap file.

Look at the registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management\DisablePagingExecutive and ensure that it is set to 0. A setting of 1 here, will turn off the page file.

And are you and the user logging into the local workstation with the local Administrator account?
The domain may have placed a GPO on the system to prevent end users from adjusting settings in the system.


If all else fails, and you have to perform a reinstall:

Typing Setup /p f (use a space between "p" and "f" ) deletes the existing settings in the Registry and installs a new one during the installation of Windows. This switch is very useful if your Registry is corrupted and you cannot fix it with a backup.

Collapse -

by whd In reply to

Poster rated this answer.
I failed to mention I also ran Ad_aware which found some possible threats, but didn't give me an option for removal. I will try to run some more. The hd has about 27Gb of free space. I will check the reg setting you mentioned and change it if needed.

Collapse -

by sgt_shultz In reply to Unable to set page file

um, did you defrag the hd?

Collapse -

by whd In reply to

Poster rated this answer.
um, Yes.

Collapse -

by TrollGod In reply to Unable to set page file

try running spybot , adaware and avg by grisoft.com with all updates first . i had a similar problem and after running all 3 3 times each the problem went away...

p.s.
if all else fails backup important files wipe and reinstall though i would try rolling back or restoring too an earlier date first

Collapse -

by whd In reply to

Poster rated this answer.
Ok. I try.

Collapse -

by donmars In reply to Unable to set page file

There are a few probabilities.
1) The setting for Maximum Size of the page file is too low, or there is not enough disk space free to expand it to that size.

2)The page file has become corrupt, possibly at a bad shutdown. In the Virtual Memory settings, set to ?No page file,? then exit System Properties, shut down the machine, and reboot. Delete PAGEFILE.SYS (on each drive, if more than just C:), set the page file up again and reboot to bring it into use.

3)The page file has been put on a different drive without leaving a minimal amount on C:.

4)There is trouble with third party software. In particular, if the message happens at shutdown, suspect a problem with Symantec?s Norton Live update, for which there is a fix posted there. It is also reported that spurious messages can arise if NAV 2004 is installed. If the problem happens at boot and the machine has an Intel chipset, the message may be caused by an early version (before version 2.1) of Intel?s ?Application Accelerator.? Uninstall this and then get an up-to-date version from Intel?s site.

5)Possibly there is trouble with the drivers for IDE hard disks; in Device Manager, remove the IDE ATA/ATAPI controllers (main controller) and reboot for Plug and Play to start over.

6)With an NTFS file system, the permissions for the page file?s drive?s root directory must give ?Full Control? to SYSTEM. If not, there is likely to be a message at boot that the system is ?unable to create a page file.?

Collapse -

by whd In reply to

Poster rated this answer.
1. There is 27Gb of free space. I set the pf to 2G.
2. I tried that already.
3. There is only one drive.
4. The message happens at boot. I will check the IAA version.
5. I will try.
6. It is already set to system.

Back to Desktop Forum
16 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums