Question

Locked

Updated BIOS on Abit AV8 board, now SATA drives aren't showing up

By jatie001 ·
I recently upgraded an older 939 board with an AMD X2 processor, but it required an updated BIOS. The BIOS flashed fine, but now the hard drives aren't being recognized, only in the RAID menu. I have to SATA drives and I don't want RAID, but in the BIOS options, there are no hard drives showing up. I tried doing a reinstall of Windows XP, but in the setup menu it says there are no hard drives in the system.

How can I tell the mobo to recognize the drives?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

Copy the SATA drivers that came with the M'Board

by OH Smeg In reply to Updated BIOS on Abit AV8 ...

To a floppy and when the first blue screen in the Windows installer appears press the F6 key to allow the Windows installer to add the SATA Drivers. On some ABIT M'Boards these are called RAID Drivers which are still the same thing and do not establish a RAID ARRAY unless you chose to configure one.

When asked insert the Floppy with The SATA Drivers copied to the Root of the floppy and allow the SATA Drivers to be installed. Once this is finished you will be asked which HDD you want to install Windows to.

Col

Collapse -

flashed to older version of BIOS

by jatie001 In reply to Copy the SATA drivers tha ...

I was able to reinstall the SATA drivers. But the system still won't boot from my SATA drives. I have Windows XP installed on them (it's been installed for the past 2 years), so I know it's there. I also plugged in an ATA drive, installed Windows on that, and was able to access the SATA drives as secondary drives through 'my computer'.

Still, it's not what I want. The mobo refuses to boot from the SATA drives.


***UPDATE***

I was able to flash to 2 older versions of the BIOS. Ver.21 (which is the update that originally supported dual-core CPU's), but still I was not able to boot from my SATA drives. I then went back to the version that came with the mobo, Ver.17, still, nothing.

Why can't I boot from my SATA drives as I was able to do before?

Collapse -

If you have added an IDE Drive

by OH Smeg In reply to flashed to older version ...

This becomes the System Default Drive and any OS will always try to boot from it no matter what.

There are 2 options here the first is to remove the IDE Drive and just leave the SATA Drive installed and the system should boot from that without a problem though a new BIOS would be better off. If you want to keep the IDE Drive you need to perform an In Place Install so you can copy some files to the Default drive which has to be formatted and they will then point in this case Windows to the SATA Drive to allow the OS to load. If you had a password in place you'll need to take ownership of your files and if you where using Windows Encrypted File System you are going to have to backup a copy of the Encryption Key or when you do an In Place Install it will be destroyed and you'll loose access to all of your data.

The directions to save a copy of the encryption key is here

http://tinyurl.com/3cd8hf

The directions on how to take Ownership of Your Files is here

http://tinyurl.com/3aw7

The directions to do an In Place Install are here but after it's finished you'll need to install any Service Packs or Patches that have become available since the system was originally installed and if you can read your Data now without any problems on the SATA Drive you should only need to follow the directions here

http://tinyurl.com/g4bv8

Col

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums