Urgent help needed on Nagios

By santosh_y20 ·
Dear Friends,

I am in a dilemma with this issue. Need your support on the below issue a on a very urgent basis.

I was able to use the check_jbossjmx nagios plugin to check jboss running on the server. However, when I execute it from the host server it is giving me the output but when I try to execute the same command on command prompt on the remote nagios server it is giving me the following error:

1) NRPE: Command 'check_jbossjmx' not defined
The command that I run for this is : ./check_nrpe -H -c check_jbossjmx 3 "jboss.jca:name=DefaultDS,service=ManagedConnectionPool" InUseConnectionCount

2) ./check_jbossjmx: line 41: /usr/local/AmritaTech/jboss-3.2.7/bin/ No such file or directory

JMX ATTRIBUTE CRITICAL - jboss.jca:name=DefaultDS,service=ManagedConnectionPool-InUseConnectionCount:

The command that I used for this is: ./check_jbossjmx 3 "jboss.jca:name=DefaultDS,service=ManagedConnectionPool" InUseConnectionCount

The command when I run on the local server and the output is:

$# ./check_jbossjmx 3 "jboss.jca:name=DefaultDS,service=ManagedConnectionPool" InUseConnectionCount

Output: JMX ATTRIBUTE OK - jboss.jca:name=DefaultDS,service=ManagedConnectionPool-InUseConnectionCount:0

As a result of which on the NAGIOS monitoring server's web interface I am getting: (No output returned from plugin)

Please help me in resolving this issue. Thanks in advance.

Santosh Balan

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Share your knowledge

Related Discussions

Related Forums