Question

  • Creator
    Topic
  • #3937757

    USB 3.2 drive seems to be much slower than I’d expect.. why?

    by stooch ·

    I purchased a Seagate One Touch 4TB USB 3.2 (apparently?) drive. Model is STKC4000400. I’m confused because when I check out the specs, it says it supports 3.2 Gen 1, “with speeds up to 10 GB/s”. Now, I of course don’t expect anywhere near that transfer speed, but what I am getting is 140MB/s, which is about the same speed as an older SATA 3 , mechanical drive.

    My PC Specs:
    Windows 10 Home 64 bit, MSI X570 Tomahawk motherboard (bios completely updated), Ryzen 9 3900X, 32GB RAM.

    Drive is plugged into a USB port labelled as “SuperSpeed” and the manual shows it as a 3.2 Gen 2 port. I get 140MB/s. I even tried a 3.2 Gen 1 port, and that was much slower… 28MB/s (Edit: I later tried that port again, and the results were better, so I’m not sure what happened in the original case).

    I’ve disabled my antivirus (MalwareBytes) as well as Windows Defender, with no improvement.

    One thing that moderately improved things was changing the profile to “Better Performance”. But really all that seems to do is ensure the first 4GB or so copies at a very fast rate (something around 1000MB/s, i’d guess) and then the rest will transfer at that 140MB/s-ish speed.

    140MB/s can’t be really what this drive should transfer at, is it? If not, what can I try and do to make this faster? Or is 140MB/s the limitation of the drive, even though it’s USB 3.2?

    Benchmarks with Crystal Disk Mark:

    [Read]
    SEQ 1MiB (Q= 8, T= 1): 152.508 MB/s [ 145.4 IOPS] < 54624.15 us>
    SEQ 1MiB (Q= 1, T= 1): 151.045 MB/s [ 144.0 IOPS] < 6933.70 us>
    RND 4KiB (Q= 32, T= 1): 1.349 MB/s [ 329.3 IOPS] < 95070.41 us>
    RND 4KiB (Q= 1, T= 1): 0.4** MB/s [ 119.9 IOPS] < 8335.39 us>

    [Write]
    SEQ 1MiB (Q= 8, T= 1): 148.059 MB/s [ 141.2 IOPS] < 56248.92 us>
    SEQ 1MiB (Q= 1, T= 1): 149.961 MB/s [ 143.0 IOPS] < 6969.90 us>
    RND 4KiB (Q= 32, T= 1): 7.200 MB/s [ 1757.8 IOPS] < 18174.63 us>
    RND 4KiB (Q= 1, T= 1): 5.148 MB/s [ 1256.8 IOPS] < 792.54 us>

    Profile: Default
    Test: 1 GiB (x5) [I: 0% (0/3726GiB)]
    Mode: [Admin]
    Time: Measure 5 sec / Interval 5 sec
    Date: 2021/12/28 12:59:47
    OS: Windows 10 [10.0 Build 19044] (x64)

You are posting a reply to: USB 3.2 drive seems to be much slower than I’d expect.. why?

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our Community FAQs for details. All submitted content is subject to our Terms of Use.

All Answers

  • Author
    Replies
    • #3938964

      To me, not unexpected.

      by rproffitt ·

      In reply to USB 3.2 drive seems to be much slower than I’d expect.. why?

      It’s another Seagate HARD DRIVE. Try other makes next time. Your test results show this drive is no speed demon and from what I see at the shop counter a maker that we find problematic drives all the time. Remember I wrote problematic, NOT FAILED. Just a maker of hard drives I will not buy.

      • #3938962

        Thanks for the confirmation..

        by stooch ·

        In reply to To me, not unexpected.

        Thanks for the reply. I think I’ll return this and just get a SATA SSD rather than a USB drive. I was only doing this because the price for 4TB was quite good.. but I didn’t realize it would be the same speed as a regular mechanical drive.

        I read some reviews of a Western Digital USB 3.2 drive, and the person mentioned the exact same thing.. 140MB/s transfer rate. So maybe that’s all these USB drives will do without going to an SSD based USB one (too pricey, and I might as well just get an internal SSD). I guess it’s more a limitation of the internal drive components than USB.. which sucks, because it seems like the USB 3.2 is useless with this kind of drive.

        I wish I could squeeze another NVMe drive in, instead, but I’ve got 3 (2 on mobo, 1 on a PCIe card) and that’s the most I can fit in here without blocking my GPU fans.

        • #3938961

          Actually your drive seems to be performing OK.

          by rproffitt ·

          In reply to Thanks for the confirmation..

          Look at the charts at https://www.everythingusb.com/speed.html where you see 127 megabytes per second on the small file test.

          Need faster? Get SSDs.

        • #3938960

          Agree..

          by stooch ·

          In reply to Actually your drive seems to be performing OK.

          That is the conclusion I’ve come to.. I thought maybe something was wrong with my USB or the drive, but it seems that I’ve hit a bottleneck not with USB but with the drive internals themselves.

          Thanks. I’m definitely exchanging this. Will likely grab a 2tb Samsung 870 Evo, even though it will cost me more.

Viewing 0 reply threads