Question

Locked

USB devices installation problem

By stewart ·
O.S. - Windows XP
Computer aleady has 3 USB devices that work fine.
I have been trying to install some new ones but up pops the Hardware Update Wizard that goes through the procedure of searching for drivers and installation software. However no drivers or installation software are required (or available)for the three different products I have tried to install. Consequently the Wizard returns the "Hardware was not Installed" message. The devices show as Drive F: but cannot be used because the computer treats them as not installed.
The three devices were:
1. A USB Hub
2. A Phillips MP3 player
3. A similar MP3 player made by Accoustics solutions.
I tried using different USB ports (which function for the older existing devices) but the results were the same.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

How old is the motherboard?

by NickNielsen In reply to USB devices installation ...

Since you have said in the other thread (http://techrepublic.com.com/5208-6230-0.html?forumID=102&threadID=207138&messageID=2144026) that Windows is fully updated and these devices won't work in any port, there are really only two possibilities:
1. You are trying to connect USB 2 devices to USB 1.1 hubs and the devices will not moderate their speed to connect to the hub.
2. You have a BIOS issue.

edit: clarify

Both of these point to an older PC or motherboard.

Collapse -

Its a possibility

by stewart In reply to How old is the motherboar ...

The motherboard is september 2003.
The possibility of usb 1 vs usb2 did occur to me but since printer and asdl are quite new I assumed they were USB and therefore computer's USB ports were also. Perhaps I shouldn't be making that assumption?

Collapse -

To check

by NickNielsen In reply to Its a possibility

Open the Device Manager, expand the USB branch, and look for an "Enhanced" USB controller. If it's not there, the motherboard doesn't support USB 2.0.

Collapse -

USB 2 Root Hub Found

by stewart In reply to To check

Although the listing includes 1 x USB2 root hub, I am puzzled by the other entries:
2 x USB
2 x USB Mass storage device
1 x USB composite drive
1 x standard EnhancedPCI to USB Host controller
Does any of that throw any light on the problem?

Collapse -

Some light

by NickNielsen In reply to USB 2 Root Hub Found

The additional root hubs are normal, as are the host controller. The mass storage devices and the composite device may be your MP3 players and external hub. I think you can remove them, then let the new hardware wizard find them again without affecting your system, but don't take my word for it.

This one is beyond my remote capabilities; you may need to take it to somebody or find a friend who is a hardware geek.

Collapse -

Many thanks

by stewart In reply to Some light

No problem.
Many thanks for your patience and helfulness.

Regards
Stewart

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums