Question

Locked

USB Drive won't work with Server 2008

By PuterGuy07 ·
I bought 10 Hitachi Simple Mini external USB drives to use as backup drives for my Server 2008 R2 server. They worked initially, but now they seem to lock up the system and I get all kinds of messages that the drives need to be formatted. They read and write just fine on XP machines, but not on my Server 2008 machine or a Windows 7 workstation

I checked the device manager and it was listed, but then went to disk management which locks up and has no new disks shown.

I bought a Seagate FreeAgent Go drive and it works just fine on my server. I tried uninstalling, rebooting and re-installing that drive in device manager, but no joy. This seems to be the case with all 10 Hitachi drives, but that one Seagate drive works fine.

I ran a SFC /Scannow and it came up clean. I have also received some Event ID 137 errors: "The default transaction resource manager on volume <drive letter> encountered a non-retryable error and could not start. The data contains the error code."

Anyone have any other ideas?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Not something that I have personal experience with but maybe

by OH Smeg In reply to USB Drive won't work with ...

The Hitachi Drives particularly if they require Software are not compatible with one of the Hot Fixes for Server 2008.

I have seen lots of cases with Western Digital Enclosures where they work fine on most machines but do not work with the Server Platforms as they are prevented by software/firmware from working in this environment. WD sell a Enterprise Drive at a greater cost to do this and take steps to prevent the Cheaper Domestic Class Enclosures from working.

What could have happened is that a Link that the Software makes use of was closed down during the recent M$ Tuesday Patches and this has caused this to start happening. That would be my guess here.

Col

Collapse -

USB Drives don't work with Server 2008 R2

by PuterGuy07 In reply to Not something that I have ...

I called Hitachi Tech Support, and they told me that the drives did not need drivers or other software, and that they should work with the server. They told me to reload the Intel chipset software which runs the USB ports on the server. Unfortunately it didn't do any good.

The drives work fine when the server is running in safe mode. It seems like there is a conflict between the Virtual Disk Manager and the drives. As soon as I start that service, it tells me to format the drives.


I am leaning towards your explanation of a defective M$ patch, or some form of corruption of the registry in the area that stores information on previously installed USB devices. I am going to uninstall the drive in Device Manager and see if that makes any difference at all, and then start removing batches of hotfixes if that doesn't work. After that, I'm running out of ideas.

Collapse -

This really sounds like a Patch Issue here

by OH Smeg In reply to USB Drives don't work wit ...

But if you know when it started you do not have to remove any Patches prior to that date. It should at least make things easier though it may not be overly helpful.

Some of the M$ Patches can not be fully removed. I've seen cases where a applied Patch makes changes that can not be undone short of a reinstall. Then of course as you apply any patches they can cause the original problem again.

Of course depending on how long this Server has been running it is also possible that a released Patch has interfered with a Older Patch to cause this problem and when you reload and patch it doesn't cause the problem again. It's more than a Nuisance but very hard to get around unless you Test all new Patches/Updates on a different server that isn't in production and can be easily dumped if required when things like this happen.

Makes things more expensive but then again that is how things should be done with all M$ Patches.

Col

Collapse -

I think that Acronis Backup & Restore update is locking volume

by PuterGuy07 In reply to This really sounds like a ...

I finally did what I should have done from the start, and that was to review the event viewer logs and find out when it started and what I, or Windows did to make it happen.

It turns out that I updated Acronis Backup & Restore 10.0 the day before, so when a USB drive was plugged in the next day, it failed.


By trial and error and stopping various services and programs, I now believe that the Machine Manager service in Acronis is causing this. If I stop the service, I can plug in a USB hard drive and it works fine.

What really baffles me is that throughout this whole thing, the one Seagate USB hard drive has always recognized immediately and has always worked fine. The Hitachi drives on the other hand, have not been very compatible.

Apparently Acronis is very touchy about using USB removable hard drives. It locks the volume of USB hard drives which causes issues if or when Windows tries to access it. Many defrag programs do this too as a protection measure.

I upgraded Acronis because the program had trouble deleting archives when the disk got full. Apparently another USB hard drive compatability issue for them. Not good.

Collapse -

Good that you have an answer

by OH Smeg In reply to I think that Acronis Back ...

Though it's probably not the answer that you wanted.

Col

Collapse -

I run windows server 2008 and have a Hitachi simple drive

by martinknapton In reply to USB Drive won't work with ...

hi i run windows server 2008 R2 and have not had a single problem with this ..
did you install the back up software and check for updates

and all so the USB port on the drives are not good they come out so if you take the back of the drive put some silicon on the 4 plates that hold the port in but don't get it on the chips

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums