General discussion

Locked

USB External HD no longer being detected

By tir ·
I went to do a backup to my Maxtor external HD via Windows XP B/U utility and find that my machine will no longer detect it as it had in the past. I have tried different USB slots and consistently get 3 beeps in my speaker when I plug in the drive and it does not appear in My Computer screen. Things I have tried are as follows:

1. I tried this external drive in another computer and it works fine.

2. I also tried other flash drives in the same usb slots and all worked well.

3. I also checked the bios boot sequence and reentered the boot sequence to what it was (removeable, cdrom, hd) and rebooted the machine with and without the external drive attached. The removeable boot device is a floppy drive.

4. A possible clue is that I recently installed RoboForm2Go passward manager (USB version) and got a boot change message but nothing seems to have changed. And I tried to reboot with and without the Robo usb flash drive installed and removed.

HELP! Surely there is a wizard that would enjoy solving this puzzle. Much appreciative to all those with opinions.

Tim

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Ooops

by CaptBilly1Eye In reply to USB External HD no longer ...

Hi tir,

Thank you for your post. Unfortunately, it is not likely to get the attention it deserves in the Discussion forum. Please re-post to the Questions forum by selecting the "Ask a Question" button. You may copy and paste your content to there.

Many do not read the Discussions forum and taking this step helps to insure that your Question gets the attention it deserves.

Please do not forget to rate answers that you find helpful as being so.

Good Luck!

Back to Hardware Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums