Question

Locked

USB External HD no longer being detected

By tir ·
USB External HD no longer being detected
I went to do a backup to my Maxtor external HD via Windows XP B/U utility and find that my machine will no longer detect it as it had in the past. I have tried different USB slots and consistently get 3 beeps in my speaker when I plug in the drive and it does not appear in My Computer screen. Things I have tried are as follows:

1. I tried this external drive in another computer and it works fine.

2. I also tried other flash drives in the same usb slots and all worked well.

3. I also checked the bios boot sequence and reentered the boot sequence to what it was (removeable, cdrom, hd) and rebooted the machine with and without the external drive attached. The removeable boot device is a floppy drive.

4. A possible clue is that I recently installed RoboForm2Go passward manager (USB version) and got a boot change message but nothing seems to have changed. And I tried to reboot with and without the Robo usb flash drive installed and removed.

HELP! Surely there is a wizard that would enjoy solving this puzzle. Much appreciative to all those with opinions.

Tim

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Got some ideas...

by tonylewis In reply to USB External HD no longer ...

If you just installed the RoboForm, you might try going to Start -> All Programs -> Accessories -> System Tools -> System Restore and choose a restore point previous to your having installed RoboForm. If your drive then works after that, you know the issue is with the software just installed. YOu can then try a reinstall of Roboform and hopefully things won't get corrupted again.

Alternatively, you can do the following first which I got from the RoboForm website:

Q: How do I fix broken AutoPlay function on USB disk?
A: In general, only device manufacturer can answer this question.
However, Microsoft offers the "AutoPlay Repair Wizard" from this link
This is what they say:
* Save it to your desktop and unplug your USB drive.
* Run the program you downloaded and insert your USB drive when prompted
* This should correct AutoPlay problem.

Q: My USB disk is not recognized by Windows when inserted? How to fix this?
A: If your USB key is still physically "healthy", this can be fixed by reloading USB driver:
* Double-click USB icon in Windows Taskbar.
* Select "USB Storage Device", click "Properties".
* Select "Driver" tab, click "Uninstall" button, wait for driver to uninstall.
* Replug your USB drive, and Windows will reinstall the driver automatically.
* Uninstalling the 2nd level in the driver tree ("USB 2.0 Flash Disk Device") may be needed too.

If USB icon in Windows Taskbar does not appear:
* Right click My Computer on desktop
* go to Hardware
* click Device Manager
* Drill into USB controllers
* go into Properties of USB Mass Storage Device.
* Or in Device Manager do View -> Devices by Connection and Drill down to your USB disk,
* Uninstall all drivers related to your USB drive.

Let us know how it turns out.

Regards,

Tony

Back to Hardware Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums