USB Flash Drive is write protected - How do I remove it?

By ddelpilar ·
While transferring files from my PC to my USB Flash Drive. I received an error message - The Disk can not be written because it is write protected. Please remove the write protection from the volume in drive \Device|Harddisk1\DR5.

How do I do this?



This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Request for Clarification

by rebwar_iraqi In reply to Clarifications

me too have a problem tell me how can i remove protet write it

Collapse -

I can help (i think)

by UserDeletedByRequest In reply to USB Flash Drive is write ...

on the usb flash drive its self there may be a switch that will add or remove copy protection

Collapse -

Do it in DOS

by da5id_NZ In reply to I can help (i think)

I have posted this elsewhere, but...

I was getting the same error with my flash drive. I also can't see the StorageDevicePolicies setting in regedit. Also, I didn't really want to reformat my drive.

What I found you can do is get into the drive through a DOS prompt.

Try this, in Windows XP - goto Start -> All Programs -> Accessories -> Command Prompt. This will open up a DOS window. Now type the name of your flashdrive followed by a colon, eg, mine was drive letter K so I type K:

Now to list the directory, type DIR
This will show your directory. At this point I left the DOS window open and went back into Windows and clicked on the drive in Explorer. The write protect error still came up, but after clicking a couple of times I could see and open the files on the drive.

Anyway, once you're in DOS you should be able to copy any files you want to another drive using the DOS 'copy' or 'xcopy' commands, and format the drive from DOS also. eg, To copy all files and directories (except empty directories) from drive C to drive A, enter

xcopy c: a: /s

You can do a search on google to find other DOS commands

Collapse -

Dos command not quite helpful

by Jones10 In reply to Do it in DOS

I did just that but I dont seem to get the results I'm expecting. It keeps saying "disk is write protected". How can I go about this? even formating it brings out the same message!

Collapse -

Zombie alert

by TobiF In reply to Dos command not quite hel ...

If YOU need help solving a problem YOU have today (and not a problem someone else had three years ago), then start your own question thread. Simply click on the button "Ask question".
If you want to get better quality in the answers, then tell us what kind of USB you have (maybe even model), kind of OS, what you have already tried.

Collapse -

Reponse To Answer

by cutiecute In reply to I can help (i think)

But what if my flash doesn't have switch?
what am i gonna do?

Collapse -


by jamesatmaisonverre In reply to USB Flash Drive is write ...

flick the switch with the padlock symbol to unlock on the stick itself

Collapse -

You are a genius

by thedame72 In reply to switch

thanks! I would never have thought to have looked there

Collapse -

Reponse To Answer

by cutiecute In reply to switch

But my Flash drive doesn't have switch. What am i gonna do?

Collapse -

Low-level format

by m3rlinez In reply to USB Flash Drive is write ...

If you are sure that there is no write-protect switch. You can try low-level format it. I have had similar problem with my Apacer Handy Steno HT 202 and used the lformat program provided at their website and it works! You can visit http://m3rlinez.blogspot.com/2007/01/just-rescued-my-write-protected-usb.html for more info about my case. Hope this helps

Related Discussions

Related Forums