General discussion

Locked

USB Flash Drive not working

By Tenamil ·
I've been searching the forums, but I'm yet to find someone with the exact problem or a solution that would work. I recently purchased a "Kingsmax" 4gb flash drive, and yesterday, it was working perfectly. This morning however I learned that my wife had pulled out the flash drive without ejecting it, and now I can't get my computer to read it. I've tried a system restore, uninstalled the drivers, tried the Disk Manage with no luck. The Disk Manage said something I don't understand "This snapin's display may be inconsistent with the removable storage service, if this problem persist please restart the snapin" I'm pretty ignorant when it comes to computers, so I don't even know what snapin means, (I think it's plug and play but I'm probably wrong) does anyone know any way that I can access my USB Memory stick without having to buy a new one?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

USB Flash Drive

by luis_carrillo In reply to USB Flash Drive not worki ...

What operating system do you have?
I hope you had a backup of the data you had on your usb drive.
Did you intall any new hardware or software to your computer system?
If your wife pull out the drive while the usb drive was transfering files at the time, then it may have corrupted the data. I would recommend for you to return it for a full refund and buy a reputable know brand.

Collapse -

Im having the same problem

by xzased In reply to USB Flash Drive not worki ...

Please, if anyone knows a way to fix tis I'll appreciate it a lot.

Back to Hardware Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums