Question

Locked

USB Hard/Flash Drives not recognized by logical disk manager

By trance3303 ·
I have multiple USB external enclosures, USB flash drives, when suddenly they all stopped working.

Whenever I plug in a USB Flash Drive, or either of my USB enclosures, the standard sound chimes in, and it even says USB Mass Storage device installed, however it does not show up under My Computer/Devices with Removable Storage. Each drive does show up under Device Manager as being present and operational. Also, they do not show up in the Logical Disk Manager, so I do not believe drive lettering is an issue. Lastly, The Logical Disk Manager and its Administrative Service are both active.

I've searched around and tried many things, including uninstalling the USB devices in the device manager and removing the .inf files, but no USB drive will show up anywhere. The USB Flash Drives also work perfectly fine on other machines, so I would assume the enclosures are operational as well.

I have 6 USB ports, tried them all, I use a USB mouse/keyboard/drawing tablet and no issues with anything.

edit: This is the error that I believe started the whole thing, from Computer Management, Event Viewer, System

RSM could not load media in drive Drive 0 of library SanDisk U3 Cruzer Micro USB Device.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try your USB Flash drive in another computer

by intrepi In reply to USB Hard/Flash Drives not ...

I'd try your USB Flash drive in another computer, if it works, then I'd go to Sandisk website and check out their support and forum to see if there is something specifically related to this model and type of Flash Drive.
I can't begin to say how much I recommend downloading, installing and using Registry Mechanic although I doubt this will fix your specific problem, there is a chance it might.
Regardless, it will fix all the errors in your registry and will definitely keep your registry free of errors which makes your PC work faster, boot faster and stay that way.

Collapse -

already tried that

by trance3303 In reply to Try your USB Flash drive ...

I've tried it in another computer, and its not just this flash drive, its this flash drive and all external hard drives.

Collapse -

You didn't mention what type of computer you use...

by OldER Mycroft In reply to USB Hard/Flash Drives not ...

Regardless of what specification the external USB components are, what is the specification of your computer?

Collapse -

xp home, amd 4800+

by trance3303 In reply to You didn't mention what t ...

what else would you need?

Collapse -

Not enough free drive labels

by Fred123456 In reply to USB Hard/Flash Drives not ...

Oops wrong answer in wrong post

Collapse -

We have seen this too. Veritas would not see the drives either.

by devin In reply to USB Hard/Flash Drives not ...

When the logical disk manager sees the drive but Veritas does not we use a VBS script that resarts the services before the backup job runs.

devin@we-are-it.com

Collapse -

Just for gigles

by jamieyielding In reply to USB Hard/Flash Drives not ...

Did you try to check disk and fix any index errors and journal errors on the c: drive. I have found that when windows acts weird a check disk on reboot usually fixes the issue. If you have not done this in a long time be prepaired for a bsd the first time it reboots, just restart the computer hit f8 and select last known good configuration and see if that fixes your usb devices.

Collapse -

Give this a chance...

by marcos_madera In reply to Just for gigles

I was in trouble about the same thing, nothing seems to be the solution (registry cleaners, device manager,etc etc etc)

So look around found the utility "USBDeview.exe", it shows a history of USB devices used in the machine and you can delete from here, so windows can recognize it again, assign a drive letter and you do your business again.

Back to Hardware Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums