Question

Locked

USB HDD not appearing on Windows XP/Linux

By Pradeep M-12379003 ·
I know this question has been asked many times in many places but I still couldn't figure out what to do with this issue.

I bought an USB 2.5" HDD enclosure to use with a HDD of my previous laptop. For some reason it doesn't recognised correctly by my desktop which is a dual boot system with XP and Ubuntu.

HDD has two partitions. One NTFS and one FAT32. Sometimes XP identifies it as a USB Mass Storage Device and shows it in My Computer as a RAW device. Same with Linux, it tries to mount the device but fails after a minute or two.

I have seen many people advice to change the drive letter of the device. To do that, this should appear in Disk Management. I've seen only once in last few months that this appears in there!

I have tried it on my laptop and on a different desktop, it works fine. So I assume this has something to do with my desktop. It is a Shuttle XPC SK41G with VIA KM266/8235 chipset.

Any ideas please? It would be great if I can sort this out without reformatting this HDD.

Many thanks in advance.

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Have look in your bios ..

And make sure that "Usb Legacy" is "Enabled".
Every usb line must have "Enabled" applied. When done DO NOT forget to "save and exit".

Please post back if you have any more problems or questions.

Collapse -

Also make sure the device has enough power

by robo_dev In reply to USB HDD not appearing on ...

Some USB enclosures have an extra power jack or include a USB Y-cable to provide extra current.

Some USB ports do not supply quite enough current, and some older hard drives draw more current than the usb cable can supply.

Collapse -

Also it depends on what the NB Drive came out of as well as the above

by OH Smeg In reply to USB HDD not appearing on ...

Things like the IBM Think Pads have a Security Chip built onto the M'Board that carries all the Passwords and so forth that the Think Pad uses to secure the system. If you then take a HDD out of the system and try to read it on a system without this Security Method it is invisible.

The solution here is to refit the drive to the IBM and remove the Passwords and any Encryption that you may have enabled. If your NB has died you can fit it to the same model NB in a USB Caddy and remove the Security and then you will be able to access it again on any computer.

If the drive didn't come out of a IBM check the jumper on the drive. All the new drives that I've used in the past 5 years don't require a jumper in the USB Caddy so if there is one remove it and see what happens. Some older 2.5 inch IDE Drives need to be set to Master not Cable Select to work correctly in the USB Caddies but these are the old ones so it's worth a try if removing any fitted jumper doesn't have any effect.

Col

Collapse -

Also, don't use an extension USB cable to connect it ...

by OldER Mycroft In reply to USB HDD not appearing on ...

This will make it invisible too.

Collapse -

Thanks, thanks, thanks....

by Pradeep M-12379003 In reply to USB HDD not appearing on ...

Hello all,

Thank you so much for all those helpful tips. I think I have tried all of them before without any luck.

1. BIOS settings seems fine as I can connect my other USB HDD

2. It is powered by USB cable and can't be anything to do with lack of power, as it works well on my laptop

3. I'm not using a USB cable extension

4. Yes it is an HDD taken out from an IBM Think Pad but I don't think security settings has to do anything with that as I don't have any problems with the HDD when I use on other PCs.

I think this has something to do with my motherboard. May be the HDD is not receiving enough power from motherboard. Because I've noticed that it mounted properly on Windows (for the very first time on my PC!) yesterday and showing the contents correctly. However I received a message an error message (unfortunately I didn't take it down) saying something to do with writing failed.

However, I have a really good news. I got a new job :-) Now I can afford to assemble my dream machine and give this PC to my parents. If you see the same message on TechRepublic again, that will probably from my dad. Just ignore it please ;-)

Thanks again guys.

Collapse -

What kind of motherboard are you trying to hook up to?

If it is more than 2 or 3 years old (we need the motherboards make and name) it will not have enough power to sustain the external hdd through the usb port. Your other computers most properly have the extra power to give to this hdd but not the motherboard you are connecting up to. Also if you have a lot of other devices connected to this computer this will cause an un-balance of power to the hdd. Something to think about before you connect.
Also go for a much beefier psu like a 750 watt.

Please post back if you have any more problems or questions.

Collapse -

Sorry about that i have seen your computer and make.

Collapse -

Writing failed?

"However I received a message an error message (unfortunately I didn't take it down) saying something to do with writing failed".

Then the hdd is on the way out or it needs MORE power.

Please post back if you have any more problems or questions.

Collapse -

If this drive is working on another computer without a problem

by OH Smeg In reply to Thanks, thanks, thanks... ...

It has to be Power or lack of it at least.

If you already have both USB Plugs plugged in to USB Ports on the M'Board the M'Board or Power Supply can not provide enough power to run the drive. The solution here is to either plug in an Optional Power Supply and connect that to the USB Caddy I have yet to see one without this option or use a Powered USB Hub.

The Power Adapter to the Caddy would be my first choice though most Powered USB Hubs only produce 500 MA at the ports and this just isn't enough to run a HDD reliably even with both the Plugs of the Y Cable being used.

Col

Collapse -

Writing failure

by Pradeep M-12379003 In reply to USB HDD not appearing on ...

Yes I think it is demanding more power. I should check this on another old PC to see if it identifies and functions properly.

Thanks again guys.

Back to Hardware Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums