Question

Locked

usb mass storage devices not recognized

By tracker77 ·
Dell Optiplex 160 was working fine then Win XP no longer recognises USB mass storage devices. All 4 USB ports give same "unknown device" message. I currently have SP3 installed. I have tried most MS and other suggested fixes to no avail, including re-installation of hardware drivers from Dell. I have tried several brands of USB thumb drives with same result. These devices work fine in a laptop that also has Win XP SP3. I am pretty knowledgeable about computers but this is completely baffling to me. I ran into some posts suggesting that SP2 may have triggered the problem.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

You don't mention how you tried to fix this problem

by ComputerCookie In reply to usb mass storage devices ...

but I would uninstall the device and restart the computer, XP should then reinstall upon restart.

Post back if you have other queries.

Jeff

Edit spelling!

Collapse -

which drivers

by w2ktechman In reply to usb mass storage devices ...

if you didnt update the chipset drivers, it likely wouldnt make a difference.

Try blowing away all USB in device manager, then install the chipset drivers and reboot.

The other things would be more HW related. I have had a power spike kill USB ports before. And a bad power supply may be the ulprit too (not powering properly to USB).
Try a USB hub (powered), see if it id's things with that.

Collapse -

Found the problem

by tracker77 In reply to which drivers

The problem appears to be caused by my Canon MX310 printer which is plugged into one of the USB ports. When I disconnect the printer, the thumb drives work fine. I just discovered this accidentally.

I hope someone can explain this.

Collapse -

partially

by The Scummy One In reply to Found the problem

the printer driver SW likely alters the ports connections to make the printer perform better. If it is in a USB hub, then other things would not be able to use the port properly, because the port settings were altered

Collapse -

A few tips here

by Jacky Howe In reply to usb mass storage devices ...

http://www.everythingusb.com/forums/showthread.php?threadid=795

Back to Software Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums