General discussion

Locked

USB memory sticks failing selectively

By dutch_gemini ·
I purchased some time ago a PlexTor PX-F256 memory stick. It has been working fine, but all of a sudden it stopped working on XP but continues to provide top service on PC's running W2K. I have tried many different hardware but with no result: the ones with XP (SP1 & 2) don't digest it, the ones with W2K run fine. I've tried also on equivalent if not same hardware to exclude particular brands from the hunt. Only in rare occasions I am able to use it on XP as well. Does anyone have similar experiences? Or a solution.

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Not specific enough

by d_g_l_s In reply to USB memory sticks failing ...

Since XP does slowly "deteriorate" over time did you take such things into consideration along with weather something else was attached or installed that might have done this? What about removing some/all of XP extras such as file caching and font/graphics shadowing, etc. Just a few of a multitude of things that come to mind in regards to XP. Were the XP systems older installation-wise? Did you try unplugging and plugging into other ports on the PC, if available?

Collapse -

None of the above

by dutch_gemini In reply to Not specific enough

None of the above helps.

I've tried to switch USB ports, turn off printers, webcams, USB hubs and replugging the stick in a different order. I've cleared the Registry for USB devices. I've tried to turn on Plug-And-Play, Remote Storage and back off, there is really no clue why it often [if not almost always] fails but then all of a sudden -on the same PC- works without problems. I always turn off any device using the tray icon (habit).

The message I get is "USB Device Not Recoginised".

The point is that it fails on XP only (and on every PC running XP), but works without problems -and 'without' really means never and never- on Windows 2000, independent of the hardware.

Neither USB v1.1 or v2.0 make any difference.

It is just XP or not XP. This is and remains the problem.

Collapse -

Have you tried...

by Benevolence In reply to None of the above

...to 'populate' the drives on the flash disk? (using device manager)

Collapse -

Would love to know how

by dutch_gemini In reply to Have you tried...

I appreciate your message, but the drive won't show up at all, it fails to load at a very early stage and as such simply is not manageable under Device Manager.

However, the very few times it makes it to loading into WinXP, then it works fine.

The problem is only related to the USB stick almost *NEVER* being recognised under WinXP but *ALWAYS* being recognised under W2K.

I have tried every possible combination of services that deal with remote storage, plug and play, you name it. Nothing, nada.

Collapse -

Need Win XP SP2

by grossjl In reply to USB memory sticks failing ...

Dutch, I strongly recommend that the PC be running Windows XP Service Pack 2. Prior to Service Pack 2, Windows XP sometimes had trouble interacting with USB storage devices.

Collapse -

It *does* have XP SP2

by dutch_gemini In reply to Need Win XP SP2

Any flavor of XP fails, also the number of KB's and Q's does not change. XP does *not* like my USB stick, W2K does like my USB stick.

Collapse -

same here

by 12345678910 In reply to USB memory sticks failing ...

I have exactly the same problem. I have 5 USB memory sticks - jump drives. Two came from Micro Center and look identical. Both work great on W2K. Neither work properly on my XP SP2 laptop. Both get a drive letter, but won't show files, write files, report size in Properties, format, report size in Computer Management/Disk Manager. I've tried everything I can.

Collapse -

Very similar to 12345678901

by alvgon In reply to USB memory sticks failing ...

Recently a trojan sliped into my box, and disconnected WinXP SP2 firewall, among other things.

Trying to solve that, reinstalled XP-SP2 over existing windows.

From that moment on, File Explorer refuses to show memory sticks that I know for sure work perfectly in another XP-SP2 box.

Strangely, they show in Computer Management/Disk Manager, but are not automatically assigned a drive letter (what demonstrates hardware side is ok).

If I assign a letter from Disk Manager and do a right click/Open, File Explorer shows their content until you do a View/Explorer bar/Folder view ... file explorer still refuses to show them in left folder view, and disk content disapears from right explorer pane.

BTW, I have applied all available updates to SP2.

Any ideas?

TIA

Collapse -

Solved similar issue

by techuser In reply to Very similar to 123456789 ...

Had very similar issue . Upgraded from Xp home to pro . After which none of my removable Usb memory cards or devices would appear in explorer .They did appear under Disk management but no drive letters allocated . I could manually assign drive letter each time but this was lost on a reboot . Also the drive would still not appear in explorer only access via disk manager and explore/open.

After lots of web search's found this suggestion that worked for me and solved the issue , all drives now show and allocated letter automatically . For reference I did not have daemon tools installed either ,


http://www.softwaretipsandtricks.com/forum/windows-xp/31147-usb-removable-memory-not-accessible-explorer-given-drive-letter.html

Collapse -

Yeeessss!!

by alvgon In reply to Solved similar issue

If you were a girl I'd kiss you in the mouth for pointing me in the right direction. If not, well ... just a big "thank you" ;-)

I neither had Daemon Tools installed, never had it. But apparently Alcohol 120% uses SPDT service too.

I only did
Step 2. Find "HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\sptd" registry key in REGEDIT and set DWORD Start value to 4 (i.e. disabled).
and this solved the problem.

Thanks again.

Back to Storage Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums