Question

Locked

USB mice not working in repaired XP system.

By compuwysepc ·
I recently built a new system for a customer, as part of the job I re-used her old system and migrated her husband's HDD into the old system. I then did a Windows repair to accomodate the hardware change, and updated to POST SP2 status.
Since then she can not get any USB mice to work, no matter which USB port she is using. The USB keyboard does function properly, and Windows will recognize the mice, including which model, but they won't function properly
I have had her verfiy that Legacy USB support was enabled in the BIOS, and she has tried to install the latest drivers, all to no avail. All of the USB mice happen to be Logitech, but I don't think that is relevant to the problem.
Any suggestions as to what is causing this unique problem.

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

I have thre same problem

by macejoe In reply to USB mice not working in r ...

I rebuilt a system, placed my old windows xp hd and everything worked. then I was reinstaling my drivers for my usb keyboard and the system locked up. Now my keyboard works but can not get my usb mouse to function. Even at login there is no mouse function. When I boot in by keyboard only, windows then recognizes the mouse by name but then states fatal error in intall. I have checked my bios and both mouse and keyboard is seen. I tried to do a repair over install with xp disk and the mouse function started to work until I rebooted the system. After this repair, windows tried to install the drivers to the mouse but same error. I am down to doing a complete clean install. I am not looking forward to backing up things with only keyboard commands. Old school is not fun. Please, any input or suggestion would be welcome.

Collapse -

No solution yet

by compuwysepc In reply to I have thre same problem

I haven't found any solution to the issue as of yet, but I can tell you that in my case, the problem is isolated to only Logitech USB mice. I discovered this after locating a Microsoft USB optical mouse, and another generic USB ball mouse. Both of those mice worked fine, the Logitech (several different models) only work when plugged into the PS/2 port with an adapter. In my case it appears as though the Logitech USB mouse drivers may be conflicting with something else specific to the transfer from one PC to another. Downloading the latest drivers from Logitech did not resolve the issue however. My suggestion is get a PS/2-to-USB adapter and see if the mouse works that way, you can't use the PS/2 mouse port for much of anything else anyway, and that frees up another uSB port for something more important, like maybe an external hard drive to backup your system to.

Back to Windows Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums