usb mouse stops working

By bob.schaefer ·
I have a dell dimension 4700c (xp home edition) it has only usb ports no ps/2 while playing a game or just using the mouse the mouse will freeze up only way to unfreeze mouse is either reboot pc or disconnect mouse and reconnect mouse I checked the drivers and the mouse says it's working properly I have also tried using a ps/2 mouse through my serial port this worked for a while but now also freezes also tried wireless keyboard and mouse and the mouse also froze any suggestions?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Sounds Like

by w2ktechman In reply to usb mouse stops working

there may be another issue with your system. Is it just the mouse that freezes, or does the system freeze?
If it is only the mouse, but everything else works fine, I would suspect a power issue with your ports, or chipset drivers need replacing (for USB)

Collapse -

Have you installed several different Mouse Drivers?

by HAL 9000 Moderator In reply to usb mouse stops working

I've only seen this type of thing when there are several Mouse Drivers installed and they cause a clash to occur spasmodically.

If the rest of the system is working OK that would be my first option and as you can unplug and replace the mouse and have it working again that sounds very much like a driver issue.

If that's the case you'll need to remove the unnecessary Mouse Drivers which depending on the makers may not be all that easy. The easy way to try to remove them is from the Add Remove Programs in the Control Panel but if there are no Mouse Drivers listed there it gets more difficult.

Prior to this starting to happen did you make any changes to the system? Like add some new software or a MS Patch?

At one stage MS had a lot of problems with USB Devices because of a security patch and their solution was to turn off the system unplug the mains and mouse leave for about 10 minutes and then plug everything back in and reboot. I don't know why it works but it did fix a problem that MS had introduced so it's worth a try.

Lets know how you get on.


Collapse -

power management

by jamesatmaisonverre In reply to usb mouse stops working

You have to check the power management setting in the bios.

Collapse -

Are you using the USB hubs on a monitor attached to the PC?

by creg In reply to power management

I saw these interesting comments about Dell GX280's having a similar issue:

"Apparantly there is a flaw in the USB uplink to the tft screens (we're currently using the model 1703FP) This screen provides a internal USB hub, but this can give errors with the USB ports at the back of the GX280 computer. A workaround is connecting the USB uplink to the front USB ports of the computer. This of course isn't the handiest solution, but Dell is working at it to fix this problem."

"For now, Dell suggested 3 workarounds:"

"1) we don't use the USB hub in the screens at all."
"2) we connect the uplink to the front of the computer"
"3) we only connect the USB hub to the back ports after the system has completely booted."

I am testing this solution on some GX620's today.

Collapse -

chipset drivers reinstalled

by bob.schaefer In reply to usb mouse stops working

went to intel site and downloaded the chipset for my machine my usb ports worked for about 8 hours before locking up again

Collapse -

Thats a start

by w2ktechman In reply to chipset drivers reinstal ...

8 hours, sounds better than before, but still!

Did you check for spyware, other mice drivers, incorrect mouse driver, etc.?

Collapse -

no spyware

by bob.schaefer In reply to Thats a start

using windows mouse driver

Collapse -

Did you get a fix

by edwardchan1 In reply to no spyware

I'm having the same problem. Have you been able to fix it?

Collapse -

No fix found yet

by kerre1 In reply to Did you get a fix

Problem occurs on Dell Optiplex GX620 & Techs aren't any help. Loaded LogiTech's driver since they were one of the Dell contracted vendors for their OKD944 USB Mouse. Still waiting on results

Collapse -

usb still problem

by bob.schaefer In reply to No fix found yet

trying to find a ps/2 mouse card so I can use mouse again. hard item to find now no one is selling them

Related Discussions

Related Forums