USB port not fully working

By marcson98 ·
I own a Dell C400 with a Pentium 3 and Xp Sp3 on it. My USB port was working fine until I tried to back up the system through it onto an external HDD w/enclosure, It made the back up, but there were problems with it when I tried to use it (icons disapearing) so I just reformatted it to use for storage for now. Since then the C400 won't recognize the external HDD anymore. The port works fine with flash drives and my usb mouse, but it shows an unknown device in Device Manager, USB section, whenever I plug it (the HDD) in, and on the unknown device 'properties' page it says there is no driver for it anymore. I tried to uninstall using the right click context menu and then rebooting but it comes up the same. I tried a different external HDD on this USB port that also worked previously, it recognized it, but it could not start the device (as noted in device manager) anymore. I tried uninstalling this 'Mass Storage Device' and rebooting without removing its plug from the usb port to see if it might restore itself. In its listing on the properties page in Device Manager it said that it had to stop the device because there was something wrong with it. Both of these HDD's are in USB 2.0 enclosures, but both enclosures are supposed to be backwards compatible with USB 1.1. They both work fine on my other Xp PC. Any ideas?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

This very much sounds like a Power Issue

by OH Smeg In reply to USB port not fully workin ...

NB's generally speaking do not have sufficient power at the USB Ports to run External Drives themselves. You need to use either a Y Cable or a External Power Adapter on the USB Enclosure.

This is because NB's do not provide the full 500 Milliamps at each USB Socket to extend the battery Life of the NB. 2.5 Inch Drives while working on 5 V DC do need the full 500 + Milliamps so you need to use either a Y cable which plugs into more than 1 USB Port, a External Power Adapter for the Enclosure or a Powered USB Hub. Even with a Powered USB Hub you may need more than 1 USB Plug to plug in for the enclosure. Back in the days of USB1 they used to say of a HDD was over 80 GIG you needed to use a Y Cable which has 2 USB Sockets that plug into the computer.

If you look at one of these leads you will notice that one has a thiner lead tot eh plug, this Plug is there just to supply power tot he HDD and is in no way used to send/receive Data. The Plug closest tot he External Drive is the Data & Power Plug and is the one that has to be plugged in if you want to properly access the drive.

Also when looking at external HDD instead of looking in Device Management look in Drive Management and see what is reported there. The Partition type is very important particularly if you have been running the drive with minimal power as you can corrupt the Partition Information if you are lucky or just trash the entire drive.


Collapse -

Thanks for the reply

by marcson98 In reply to This very much sounds lik ...

That's interesting. I didn't know what the extra lead was for on the Y cable. Well, I tried it out as you suggested and not much difference. Instead of it being listed as an "Unknown Device" in Device Manager it was listed as a Mass Storage Device (at least it recognized something about it), but it never got a drive letter or showed up in My Computer or Windows Explorer or Disk Management for use. Also in Device Manager it said it couldn't find a driver for it. One other symptom that appeared at the same time as the problem with the USB port no longer recognizing HDD enclosures is that the balloon that appears right above the system tray and tells you that it is "Safe to Remove Hardware", stopped showing up. When you unload devices using the "Safely Remove Hardware" icon, the flash drives I use still do get unloaded, as I can watch their drive letters disappear in Windows Explorer, but the informative baloon that tells you when to pull them out of the socket ("Safe to Remove Hardware") never shows up anymore. What I have started doing is to just wait a few seconds after the drive entries disappear, and then I physically remove the drives from the port.

Collapse -

RE: Mass Storage Device

by OH Smeg In reply to Thanks for the reply

Is the Interface card between the USB Lead and the HDD, that is what you should see if the HDD was not fitted tot he enclosure when you plugged in the Enclosure.

If these drives are working on another computer the only thing I can think of here is to open the Device Manager remove all of the USB Devices including the Hubs and restarting the computer. Allow Windows to find and install the required Drivers and then reboot the system.

Try plugging in both USB Sockets on the Y Cable and see if it works now.


Collapse -

Thanks again

by marcson98 In reply to RE: [i]Mass Storage Devic ...

Really appreciate your help with this. Unfortunately, I have also been looking around for a solution on the web and other people with this type of problem who have tried some different things. Some people also suggested what you did and in many cases they reported it fixed the problem. Not so with mine. I tried the Microsoft Hotfix that matches the description of my symptoms exactly also and it didn't work either. On the hotfix page Microsoft says that they recognize an issue with this problem that needs to be addressed and they are working on a patch for the future. I think this is probably an issue with the way their OS interacts with what is on this model of Dell Laptop and maybe triggered by the USB enclosure being a very cheap foreign import of unknown quality. Anyway I can live without it, all my other flash drives and USB mouse work fine on it. If I decide it really bothers me I will try reinstalling Windows with a fresh install, but I don't have a backup yet or the installation disk (because it came without it) so I'll just try it like this for a while. Otherwise it works perfect. Thanks for the help and for telling me what the second lead on the Y cable is there for. I was wondering about that.

Collapse -

Your Welcome EOM

by OH Smeg In reply to Thanks again
Back to Storage Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums