Question

Locked

USB Ports Stopped Working After Driver Update

By josuff36 ·
Hi:

All of my USB ports (6) have stopped working.

Here are the PC stats:

Windows 7 Pro
2GB RAM
2.8Ghz Intel Pentium D / multi-core
Board: Dell Inc. 0YC523
Bus Clock: 800 megahertz
BIOS: Dell Inc. A07 01/08/2007
750GB internal hard drive
2TB external
ATA Channel 0 [Controller]
ATA Channel 1 [Controller]
Intel(R) 82801G (ICH7 Family) Ultra ATA Storage Controllers - 27DF
Intel(R) ICH7R/DH SATA AHCI Controller
Silicon Image SiI 3512 SATALink Controller
Intel(R) 82801G (ICH7 Family) USB Universal Host Controller - 27C8
Intel(R) 82801G (ICH7 Family) USB Universal Host Controller - 27C9
Intel(R) 82801G (ICH7 Family) USB Universal Host Controller - 27CA
Intel(R) 82801G (ICH7 Family) USB Universal Host Controller - 27CB
Intel(R) 82801G (ICH7 Family) USB2 Enhanced Host Controller - 27CC
Angel II MPEG Device (2x)
Creative Game Port
Creative SB Audigy 2 ZS (WDM)
RADEON X600 256MB HyperMemory [Display adapter]
RADEON X600 256MB HyperMemory Secondary [Display adapter]

After installing Windows 7, I used DriveMax Agent to update as many drivers as I could. The one thing I didn't do was create a system restore point so I could backtrack in case something didn't work.

After one of the USB driver updates, all of my USB ports stopped working. I can still charge my iPhone, but I get no connectivity (iTunes / iPhone won't talk to each other, printer doesn't work, etc). Since I didn't create a system restore point to go back to an older driver, I located the older chipset drivers and installed them. The ports will didn't work.

I also tried these things:

1) Unplug PC from the wall to reset.
2) Uninstall the USB drivers, reboot, and let Windows reinstall.

Device Manager shows them working properly and again, my iPhone charges. But the printer says it's offline no matter which port I plug it into and no other USB devices work in any of the (6) ports.

Does anyone have any idea how to get them working again?

Thanks in advance for any help you can provide.

Joe

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

Go out back

by santeewelding In reply to USB Ports Stopped Working ...

And, shoot yourself.

What was broke that you had to fix it with an unceremonious application of DriveMax Agent?

Just for the **** of it?

Collapse -

I missed

by josuff36 In reply to Go out back

I tried to use DriveMax Agent to shoot myself but it loaded bullets that were the wrong caliber...probably should stay away from software like that...

Collapse -

No

by santeewelding In reply to I missed

Just learn what the business end and the back end of the thing is.

Collapse -

RE:- After installing Windows 7, I used DriveMax Agent

by OH Smeg In reply to USB Ports Stopped Working ...

Well I think you have your answer here. You used something that not only wasn't required but is downright counter productive. Of course you can still charge your I Phone/Pod as there is the 5 V DC available at the USB Ports but the OS has been corrupted and need reinstalling.

Grab your copy of 7 and install with a Format of the HDD. If you have data on this drive that you have to keep back it up before starting and then you can reinstall all of your Software and whatever Hot Fixes 7 needs. When you installed 7 it installs all the required drivers and you do not need to update these unless there is a specific problem.

Col

Collapse -

Thanks

by josuff36 In reply to RE:- [i]After installing ...

I wasn't aware that updating drivers to the most current was something I should steer clear of, as I thought 'newer is always better'.

Little did I know...

Thanks for your help!

Joe

Collapse -

My man

by santeewelding In reply to Thanks

If you didn't know, I'm here to tell you: OH Smeg deserves a thumb.

What are you -- unappreciative of his time and attention?

He was also charitable with you.

Collapse -

No driver rollback?

by seanferd In reply to Thanks

That has always been available from driver properties after updating a driver.

Back to Software Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums