USB printers stopped working

By brian ·
For a few years I have been happily printing with 2 or 3 printers connected to a 4-port powered USB 2 hub at the end of 5 metre passive cable.

Suddenly, a couple of weeks ago (actually not long after I installed Nokia PC Suite 7) the printers decided not play ball. Prints would often fail completely or print out a line of gobbledygook or even print the top inch or so of a page before giving up and spewing out the paper. But the USB system still recognised that they were there and bleeped when unplugged.

One of the printers failed completely, so it has been replaced. I now find that if I connect printers directly (i.e. by avoiding the hub) they work - even by putting an A-B cable in the end of the 5m run. Connecting through the hub, neither of the printers wants to know.

Could I expect them to work if the 5m run were an active cable? Or is there a special type of hub that I need to install?

Incidentally I have swapped out the hub and used a different 5m cable (passive; I don't have an active one). I have even connected up to a different computer. It also makes no difference. Neither is there any difference if I go through an external hub at the PC end of the 5m run or connect it straight into the Mobo USB ports.

I am doing my nut because everything I have tried fails - yet the system has worked perfectly for a long time.

Is it hub? Is it cable? Or is it something else. Grateful for your views!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

It could be the 5 meter Cable

by OH Smeg Moderator In reply to USB printers stopped work ...

As that is a bit long for reliable USB printing. What could have happened is that the USB lead is now being exposed to more RF Interference than it was previously and it is now causing problems.

Look to see if a new Wireless Network has been established in your area or a new Wireless device like a Cordless phone has been added. Things like this can adversely affect USB devices.


Collapse -

I have a new cordless phone

by brian In reply to It could be the 5 meter C ...

Thanks for that suggestion, Col. The problem does coincide with me replacing my cordless phone system.

I have just obtained a 5 metre active cable and am going to try that.

Collapse -

Just in case its not the phone

by Tearat In reply to USB printers stopped work ...

Did you try the printers one by one?

Are the printers USB 1 or 2?

It is one of two things, speed or interference

Interference can come from the printers
Try moving everything to another place
Check the power plugs and sockets

What ever affected the printer may have affected the hub

Have you tried other USB devices?
A mouse will do

One more thing if the hub will work with out power try it

Collapse -

Tracking the fault

by brian In reply to Just in case its not the ...

Hi Techno Rat,

Thanks for your thoughts.

Yes I tried them one by one via the hub - no repsonse. Connected directly - fine.

They are USB2.

I have moved them around within the confines of the space I have available and turned off printers not being tested; but the printers have worked fine for 2 years.

All my other usb devices work (but I have not tried them in the printer hub - good thought).

I have tried the hub unpowered.

Incidentally I found that the 5 metre cable I was using was active, not passive, but I replaced it anyway. No joy. I replaced the hub again (this is the third hub I used here) and it /seems/ to be working for now. But I need to check the stability.


Collapse -

Something else that may help

by Tearat In reply to Tracking the fault

Use an active cable that is shorter plus another cable
Like 2? meters times 2

It may help to cut down on interference
The powered hub acts like a repeater
With the active cable you have two repeaters side by side at one end

Or you could use a shorter cable and move the hub closer to the pc
Then use longer cables from the printers to the hub

One of those may work

Collapse -

If that's the 3rd Hub

by Jacky Howe In reply to USB printers stopped work ...

that you have replaced and the Printers are working now I would be looking at the power source. If its a Power Board either replace it or have it tested along with the Power Outlet.
<i>Keep us informed as to your progress if you require further assistance.</i>
<font size="1"><i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome. </i></font>

Collapse -

You may need

by Tearat In reply to If that's the 3rd Hub :D

To get the printers and anything else that connects to the hub tested

It is possible for power from the printers to damage the hub
In NZ we have a 3-pin mains plug
1 pin for phase power
1 pin for neutral
1 pin for earth

The earth pin bonds all the frame grounds together
I have seen high voltages on the shield of USB connected devices
Those did not have a grounded frame

Collapse -

And with Double Insulated products

by OH Smeg Moderator In reply to You may need

These do not have a Earth Pin as they are not earthed. So things like Printers and USB Hubs are not earthed as there are at least 2 layers of insulation between the Active Electrical Parts and the external case of the product.

These are actually far less safe if they are earthed and far ore likely to introduce problems.


Collapse -

Low voltage

by brian In reply to And with Double Insulated ...

I understand what you are saying, thanks. All the hubs I have are low voltage DC through a transformer, so double insulation is not a requirement.

Collapse -

Powered USB Hubs should be supplying

by OH Smeg Moderator In reply to Low voltage

500 Milli Amps at each USB Socket so that you can plug in devices that are powered from the USB and they work.

The advantage with this is that the actual M'Board doesn't have to supply the power for these devices.

Earth Loops shouldn't be a problem here but if problems persist check the Power Board or whatever it is you are using for correct function on the Active Neutral and Earth.


Related Discussions

Related Forums