Question

Locked

USB problem with Flash drives are not recognized and showing up

By rwries ·
Hi,

I have a problem with USB Flash drives are not recognized and showing up on either MY Computer or Windows Explorer. In fact their autorun features don't work either. What could be wrong.

Thanks.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Assuming that this is some form of Windows that you are using

by OH Smeg In reply to USB problem with Flash dr ...

Open Drive Management and see what is being shown there when you have one of these Flash Drives Plugged in.

Odds are that provided that this isn't involved on a Domain with Restrictions on Thumb Drives or other USB Devices that the OS is not generating a Drive Letter for the Thumb Drives when you plug them in.

Obviously I would expect that you have tried these in another computer to see if they actually work and if they do that you have tried them in different USB ports to rule out a failed USB port on your computer.

Col

Collapse -

A couple of things to try

by Jacky Howe In reply to USB problem with Flash dr ...

1. Click Start, point to All Programs, point to Accessories, and then click Command Prompt.
2. At a command prompt, type the following command, and then press ENTER:
set devmgr_show_nonpresent_devices=1
3. Type the following command at the command prompt, and then press ENTER:
start devmgmt.msc
4. Troubleshoot the devices and drivers in Device Manager.

NOTE: Click Show hidden devices on the View menu in Device Managers before you can see devices that are not connected to the computer.
5. When you finish troubleshooting, close Device Manager.
6. Type exit at the command prompt.

Phantom Devices are icons that appear translucent or faded.

Delete all of the Phantom devices that are not connected to the computer. Check under Portable Devices and Universal Serial Bus controlers. Also uninstall the device if it is listed in under Portable Devices. Remove Unknown device as well.
Under Universal Serial Bus controlers remove all USB Universal Host Controlers.

Uninstall all devices under USB Controllers.
Uninstall all devices under Disk Drives.
Do the same under Storage Volumes leaving the exposed Generic volume.
Don't accept any reboot prompts until you are finished.
If you have a yellow ! with unknown devices, uninstall all of the entries there as well.

Restart the System and see if it is detected.


If it is now detected but it is not allocated a Drive letter try this.

Write down all fixed Disk and CD/DVD drive letters so as not to delete them. DO NOT delete any of the fixed hard disk drives or CD/DVD optical drives registry values.

1. Login with Administrative privileges.

2. Disconnect all USB or FireWire storage devices.

3. Open Registry Editor by typing regedt32 in the Run box and navigate to the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices. Right click on MountedDevices and select Export. Save this file as you may need it in case something goes wrong. Save it as Devices.reg, it should default to My Documents.

4. Under HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices there will be registry keys with the name that resembles the format of \DosDevice\X: where X can be any alphabet letter which corresponding to your physical system drive letter.

5. Delete all possible USB drives, FireWire drives and external drives which have a drive letter.

<b>DO NOT delete any of the fixed Hard Disk Drives or CD/DVD optical drives registry values.</b>

Exclude \DosDevice\A: which normally reserved for floppy disk drives.


Try a Powerd USB Hub.

Your (PSU) Power supply Unit may not be providing the correct voltages. Maybe your USB ports are starting to fail.

Back to Desktop Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums