Question

Locked

USB-Serial adapter works until reboot

By CharlieSpencer ·
I've got a Dell desktop with a single serial port. I want to use it to replace a much older Compaq system running Pitney Bowes SendSuite shipping software. The software runs fine on the Dell, it's the weight scale that's giving me problems.

If I connect the scale to the serial port, the software doesn't communicate with the scale. (There's a built-in comm test in the application; it reports "serial port timed out".) I updated the BIOS, made sure the COM port settings matched between the Compaq and Dell, etc; no change.

In desperation I tried a USB-serial adapter. Initially the connection initially failed the test. If I adjust any setting, (change the COM port number, change the timeout period, toggle FIFO on or off) the software and scale begin talking. It doesn't matter what COM port settings I change or what I change them to as long as the settings match in all applicable places (Hardware Manager, USB-serial driver, application setting for the port to monitor, etc.) Everything is fine and I can log off and on without problem. But if I reboot or cold boot, the software reports commo problems until I tweak a setting. Then everything is fine until the next reboot.

Anybody had similar problems with USB-Serial adapters? Any advice? I know it's too much to hope that someone else out there is working with P-B scales on a Dell.

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

We have em

by LarryD4 In reply to USB-Serial adapter works ...

We use the PB scales but not on a PC, they are attached directly to the giant mail sorting monster. I did have issues though, we upgraded the monster and the new monster had USP ports instead of serial ports. So we had to upgrade the scale to a USB scale from PB..

Maybe you can look in to the same, just get a usb scale?

Collapse -

Doesn't appear to be an option.

by CharlieSpencer In reply to We have em

Inside the software is a setting for what communications port to monitor. It lists 10 COM ports, but no settings for USB, parallel, SCSI, or other input type. I'll ask PB but I'm not optimistic.

Collapse -

Back to COM Port

by willcomp In reply to USB-Serial adapter works ...

Does the On-board Serial Port have an IRQ set in BIOS or is it set to Auto?

PnP BIOSes and XP will try to share IRQs. Ensure that serial port has a dedicated IRQ and address. I'd recommend IRQ4 and 3F8 -- the standard Com1 settings.

Collapse -

Tried that

by CharlieSpencer In reply to Back to COM Port

The BIOS has settings for Auto, COM1 (IRQ4, 3F8), COM3, and Disabled. I tried each of the first three with no difference in results when I was still playing with the on-board COM port. When I started working with the USB adapter I set the port to Disabled; the setting didn't appear to make any difference as long as I made sure the USB didn't try to use 1 or 3.

Collapse -

IRQ Assignments

by willcomp In reply to Tried that

Did you check resources by connection in Device Manager?

Collapse -

Yep.

by CharlieSpencer In reply to IRQ Assignments

No conflicts, and the assigned resources match what's specified in the BIOS.

Collapse -

Some USB/Serial adapters

by TonytheTiger In reply to USB-Serial adapter works ...

look like a new device every time you reboot. Especially if you don't plug it into the same USB port every time. Next time you reboot, check Device Manager and see if you have a "Com15" :)

You might need to get a different adapter. We've had good luck with the Radio Shack one.

Collapse -

It's present

by CharlieSpencer In reply to Some USB/Serial adapters

The device remains present in Device Manager after a reboot, with the correct settings.

I suspect you're correct about a different adapter. I was a bit surprised when the scales worked with the adapter when the physical COM1 when nowhere. Hey, these things are cheap and I don't expect to have much trouble getting a green light to order half a dozen different ones. The one I borrowed for testing is from a work cell with relatively new laptops and no serial ports. The person I got it from mentioned they had seen infrequent connectivity issues with this model but it's all they had at the time.

Collapse -

Try this

by AruJammer In reply to It's present

In most cases, you have to install the drivers first and then after a restart you can finally plug in the adapter.
Then windows will automaticly "see" the new hardware and you can proceed with the installation.

If still no work, try to change the com poort in the hardware management

Collapse -

Tried that

by CharlieSpencer In reply to Try this

Drivers were the first thing I did when I started testing the adapter. I've changed the COM port several times; no difference. The adapter is still unusable after a reboot until I alter a setting.

Back to Windows Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums