Question

USB Write Protection (Many methods online didn't help)

By Rezznorock ·
Tags: Software
I was given a USB and told that it is bought from China (I can keep it if I can fix it). The issue with this USB is when I first open it, Windows told me that it must be formatted. When I try to format it, a popup appears telling me that it is write protected.

List of things I tried and failed
- diskpart
- registry
- (most of) 3rd party softwares
- The USB has no physical switch locks

More info

From disk management it shows 32GB RAW and 468GB Unallocated Space
From diskpart list disk it shows 500GB total and 468GB Free
From diskpart list volume it shows 32GB RAW (also tried formatting volume directly and failed due to write protection)

Thank you in advance
Thread display: Collapse - | Expand +

All Answers

Collapse -

x

by zzx159 In reply to USB Write Protection (Man ...

I afraid you should change a new USB. If it is a new USB, I think you should call the customer service center or post the problem on the website
By the way:
How did you use diskpart.exe? Did you use "attributes disk clear readonly" command in diskpart. This is a way to remove the write protection.
And I was use third-party tool AOMEI Partition Assistant to format a USB flash drive. It worked for me. Maybe it is the final attemp. you can refer to the page:https://www.diskpart.com/articles/remove-write-protection-from-hard-drive-0310.html

Related Discussions

Related Forums