General discussion

Locked

user login

By Old-Flyer ·
I am having problems loggin in as any users except root. The last thing I can remember I did as far as changes to the system was to enable disk quota. I have even tried adding user thinking that maybe the problem was somewhere in a login script orprofile. When I try to login as any user but root I get the following error messages and what appears to be a normal shell prompt, however, if I use the full path to access a commands, I get a permission denied message. I checked the permission of the commands and they are set to -r-xr-xr-x The following is an example login session.

login: Username
Password:
Last login: day_date from hostname
bash: id: command not found
bash: id: command not found
bash: id: command not found
[: too many arguments
bash: id: command not found
bash: dircolors: command not found
[usrname@hostname usershome]$

I'm out of ideas as to where to look.

Ron

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

user login

by bklein In reply to user login

First we need to see the resluts of repquota -a.

Have you tried to completely turn quotas off?

Collapse -

user login

by Old-Flyer In reply to user login

I believe I have found the solution. Some how the premissions for the /bin directory got change to rwx------ and it needed to be rwxr-xr-x.

Thanks

Back to Linux Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums