Question

Locked

User permissions, ownership, can't view videos

By ohm.paul ·
I currently have a few systems set up at our store locations that have cameras hooked up to them which are recording at all times and saving to the user's computer. The camera software runs as a service using the administrator credentials and the teller at the store uses a restricted user account.

When I log on as the administrator, I am able to view the video files fine, however, when the user logs on as the restricted user, he double clicks the video file, and windows media player opens as if it is going to show it, but the video is all grey, as if it is not allowing that user to see it.

I created a separate "power user" account and a separate administrator account, but neither account is able to view the actual video, just a grey picture. I am assuming that this has to do with ownership and permissions.

I have set up the restricted user to only be able to view, read, and write for the directory where the videos are saved via the Security tab in the folder's options. I applied those permissions to all child objects, and so I do not know why nobody but the administrator can view them.

The strange thing is that when logged on as the restricted user, I can see the thumbnails of the video and I actually see an image from the video, so it is not grey there...which doesn't make sense. You would think that if windows can see the thumbnail, then it would be able to view the video.

The system is Windows XP Pro. I have had a similar problem on another system, where the restricted user was unable to even navigate to the directory of the video files without throwing a runtime error.

So I am wondering, is there anything I can do to allow the restricted user have ownership or permissions to view the actual video, but still prevent that user from being able to delete the videos (for obvious reasons).

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

You can

by IC-IT In reply to User permissions, ownersh ...

allow Read and Execute.
Also verify that the player has permissions.
On some systems there is a lockout function that diverts the recordings to a special folder that locks out all but the designated user, verify that option is not set. Others create special permissions similiar to this;
http://www.indigovision.com/learnabout-iaminipvideo.php

Collapse -

It's a codec issue

by robo_dev In reply to User permissions, ownersh ...

I think the issue is that only the admin account allows programs to install and run automatically, so a missing codec issue is fixed automagically when you're an admin.

I think the fix is identify and manually install the missing codec.

It could also be a missing activeX control if the videos can play in a web browser.

As a test, try this free player, it does not
live and die based on what codecs are avilable.
http://www.videolan.org/vlc/

Site for making things work with limited accounts:
http://nonadmin.editme.com/

Collapse -

vlc a no go

by ohm.paul In reply to It's a codec issue

That seemed like it could have very well been the problem, but I installed VLC and tried to play the videos, and nothing played. I went to File -> Open File and when i click play, it seems like it is going to do something for a split second, then nothing happens.

I noticed that if the users are able to run the camera software itself, they would be able to watch the videos that way without being about to stop the recording. However, I have the service set up to run as Administrator, and so the program never interacts with the desktop. If i elect to run the service as the "LocalSystem Account" and "Allow service to Interact with Desktop" then the service doesn't start until someone logs in. I want it to be recording as long as the computer is on... So is there any way to create a service that uses Administrator's credentials, and ALSO allows it to interact with the desktop?

If I could somehow set up WMPlayer to run with Administrative credentials all the time, without the restricted user needing to enter the Admin password, that might work also...

Any other ideas?

Collapse -

Some Microsoft help pages?

by robo_dev In reply to vlc a no go

Security and WMP 11
http://www.microsoft.com/windows/windowsmedia/player/11/security.aspx

http://www.microsoft.com/windows/windowsmedia/knowledgecenter/mediaadvice/0071.mspx

Does it work when you use the 'runas' command?

This would verify that it's just the app, and not file permissions, codec, etc.

Although a real ugly workaround, you can plug the admin password into a VBScript to use runas without prompting for admin password:

http://vlaurie.com/computers2/Articles/xprunas.htm

Collapse -

Works with Runas

by ohm.paul In reply to Some Microsoft help pages ...

I ran wmplayer.exe using the RunAs and entered the administrator creds, and the videos play fine after opening that. So, it seems as though it really is just WMplayer messing things up. I suppose I will have to read into some WMplayer documentation (the computer is using WMPlayer 9...(i wonder if a newer version wouldn't have this problem)...

If I can't find any solutions from Microsoft, I guess I'll have to do the VBScript thing, although I know nothing about VBScript. I also wouldnt want the restricted user to be able to open the vbscript and view the admin password somehow.

Collapse -

VBScript works

by ohm.paul In reply to Works with Runas

I set up the VBScript and everything seems to work from that shortcut, however, the restricted user is still able to browse to the Windows Media Player directory and open the vbscript in notepad, which shows the admin password in plain text. I'm not sure how I would go about preventing the user from opening it in notepad but still allow him to run the script...am I overlooking an easy solution to this?

Back to Hardware Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums